New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      04-17-2013, 09:11 PM   #1
shashi27
Private
 
Drives: 11 Z4 35is
Join Date: Jan 2011
Location: NJ, USA

Posts: 84
iTrader: (0)

Serious shuddering / stumbling

Have a 35 is with about 40k miles. Past couple of days felt mild stumbling at start up. Just to be sure it wasn't bad gas I filled it up. This morning it ran really rough. I always let the car warm up for 5 to 10 minutes as I get ready to leave the house in the morning. When I got into the car it felt like an old carb car where I had to give it gas to keep it from stalling. When I started to move I thought it would stall. It violently shuddered a few times as a i drove it and the check engine light came on. I thought my engine was going to grenade. I figured I would limp it to BMW. They couldn't take it in today but after 15 minutes of driving I had no issues. Drove it at lunch and way home with no issues or stumbling. BMW will take it in tomorrow night. HPFP or 02 sensor? Car is parked in driveway outside as I am working on suspension of another car. Thoughts.
shashi27 is offline  
0
Reply With Quote
      04-17-2013, 10:41 PM   #2
tranquility
sportscars only
 
tranquility's Avatar
 
Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Toronto

Posts: 1,458
iTrader: (0)

Hmmm, not sure if idling perhaps is the cause of the prb. That is an awful loooong time to idle. I think that w/ these engines, you can pretty much start up, wait a few seconds and drive off, just taking it easy for the first few kms.

That's just my layman's guess. Let's hear more from the better-informed.
tranquility is offline   Canada
0
Reply With Quote
      04-17-2013, 11:47 PM   #3
R1robot
Private First Class
 
R1robot's Avatar
 
Drives: 2003 Z4 2.5i
Join Date: Jan 2013
Location: Texas

Posts: 111
iTrader: (0)

I would understand if it was snowing out and you let your car warm up for that long, otherwise you let it idle too long. Still though, long idling shouldn't be a problem. Let us know if BMW finds the problem.
R1robot is offline   United_States
0
Reply With Quote
      04-18-2013, 12:09 AM   #4
juhap
Lieutenant
 
juhap's Avatar
 
Drives: sDrive35i
Join Date: Jun 2009
Location: Finland

Posts: 530
iTrader: (0)

My money is on fuel injectors. You wouldn't be the first one here who's had to have (some of) them replaced.
juhap is offline   Finland
0
Reply With Quote
      04-18-2013, 06:14 AM   #5
jparnes1
Lieutenant Colonel
 
jparnes1's Avatar
 
Drives: 2006 525xi, 2012 Z4 35i
Join Date: Jan 2010
Location: Rochester, NY

Posts: 1,701
iTrader: (0)

HPFP no, not in a 2011. That problem was solved.
__________________
2012 Z4 35i, ED 2/24/2012, Melbourne Red Metallic, Black Leather, Carbon Trim, 6MT, ///M Sport, CW, PP, PS, NAV, CA, LED Angel Eyes, red calipers, pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side markers, Extra Enjoyment Package.
jparnes1 is online now   No_Country
0
Reply With Quote
      04-18-2013, 02:09 PM   #6
z4z4z4
Lieutenant
 
z4z4z4's Avatar
 
Drives: 2002 M3, 2011 Z4, & her 740Li
Join Date: Mar 2010
Location: mild mediterranean breezes

Posts: 525
iTrader: (1)

Before going to dealer, try finding an autoparts business that lends a code reader to see if any or what code(s) are thrown.
Here's a link to some N54 codes.
http://www.n54tech.com/forums/showthread.php?t=3930

I'd also recommend new sparkplugs if they are the originals. Most boosted cars change plugs between 20k and 25k miles.
http://www.burgertuning.com/N54_BMW_...t_adapter.html

Good Luck!
__________________

BBS-ER-HPF-iJDM-LUX-MachtSchnell-PSS-Remus-Tekarbon
z4z4z4 is offline   United_States
0
Reply With Quote
      04-18-2013, 02:13 PM   #7
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,263
iTrader: (0)

Send a message via MSN to ManiacGT
Quote:
Originally Posted by jparnes1 View Post
HPFP no, not in a 2011. That problem was solved.
Ha... so they'd have you believe.

I'll go injectors then hpfp, worst case turbos. Injectors are my favourite guess.
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      04-18-2013, 02:37 PM   #8
jparnes1
Lieutenant Colonel
 
jparnes1's Avatar
 
Drives: 2006 525xi, 2012 Z4 35i
Join Date: Jan 2010
Location: Rochester, NY

Posts: 1,701
iTrader: (0)

Quote:
Originally Posted by ManiacGT View Post
Ha... so they'd have you believe.

I'll go injectors then hpfp, worst case turbos. Injectors are my favourite guess.
Sorry to disagree Maniac. The latest pump version has had no problems. If you know of one, it's an outlier.
__________________
2012 Z4 35i, ED 2/24/2012, Melbourne Red Metallic, Black Leather, Carbon Trim, 6MT, ///M Sport, CW, PP, PS, NAV, CA, LED Angel Eyes, red calipers, pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side markers, Extra Enjoyment Package.
jparnes1 is online now   No_Country
0
Reply With Quote
      04-18-2013, 03:51 PM   #9
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,263
iTrader: (0)

Send a message via MSN to ManiacGT
I think you mean has had no problems 'yet'

As they keep making more and more versions, you'll have to forgive my scepticism...
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      04-18-2013, 03:58 PM   #10
jparnes1
Lieutenant Colonel
 
jparnes1's Avatar
 
Drives: 2006 525xi, 2012 Z4 35i
Join Date: Jan 2010
Location: Rochester, NY

Posts: 1,701
iTrader: (0)

[quote=ManiacGT;13845698]I think you mean has had no problems 'yet'

As they keep making more and more versions, you'll have to forgive my scepticism...[/Q

The point is that the same version has been in place since 2011, no problems.
__________________
2012 Z4 35i, ED 2/24/2012, Melbourne Red Metallic, Black Leather, Carbon Trim, 6MT, ///M Sport, CW, PP, PS, NAV, CA, LED Angel Eyes, red calipers, pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side markers, Extra Enjoyment Package.
jparnes1 is online now   No_Country
0
Reply With Quote
      04-18-2013, 08:20 PM   #11
shashi27
Private
 
Drives: 11 Z4 35is
Join Date: Jan 2011
Location: NJ, USA

Posts: 84
iTrader: (0)

She had no issue today. I dropped her off tonight at the dealer so fingers crossed. I didn't mention before I have an ESS tune so hope it is not the turbos. Had the tune for over a year with no issues.
shashi27 is offline  
0
Reply With Quote
      04-19-2013, 04:23 PM   #12
morfinx
Shenanigans
 
morfinx's Avatar
 
Drives: E89 Z4 sDrive35i
Join Date: Jul 2010
Location: Austin, TX

Posts: 1,222
iTrader: (0)

Exact same thing happened to me. Dealer replaced HPFP (the 2nd replacement) and 3 injectors.
__________________
E89 Z4 sDrive35i 7DCT "Zayna", Alpine White/Coral Red
E92 335i 6MT "Calixta", Space Grey/Coral Red [Retired]

morfinx is offline   United_States
0
Reply With Quote
      11-17-2013, 02:02 PM   #13
shashi27
Private
 
Drives: 11 Z4 35is
Join Date: Jan 2011
Location: NJ, USA

Posts: 84
iTrader: (0)

Resurrecting this as the car consistently stumbles at startup. Definitely some type of fuel starvation. When up to temp car runs good. I have to turn off and restart for the car to stop stumbling. Sometimes it shudders like a Harley and other times it sounds like when you put your finger on an oscillating fan, like a propeller. Blrrrrrrrrrrrrrrrrrr, instead of whroommmmmmm. Like a castrated car. Back to dealer. I am going to have them check injectors.
shashi27 is offline  
0
Reply With Quote
      11-17-2013, 10:05 PM   #14
Longboard
New Member
 
Drives: 2009 Z4 sDrive35i
Join Date: Mar 2013
Location: CA

Posts: 27
iTrader: (0)

Quote:
Originally Posted by shashi27 View Post
Resurrecting this as the car consistently stumbles at startup. Definitely some type of fuel starvation. When up to temp car runs good. I have to turn off and restart for the car to stop stumbling. Sometimes it shudders like a Harley and other times it sounds like when you put your finger on an oscillating fan, like a propeller. Blrrrrrrrrrrrrrrrrrr, instead of whroommmmmmm. Like a castrated car. Back to dealer. I am going to have them check injectors.

Let us know because I have some really ruff idle at gold start up that started a month back.

Longboard
Longboard is offline  
0
Reply With Quote
      11-17-2013, 10:08 PM   #15
Lambobimmer
Captain
 
Drives: 2009 Z4 sDrive35i DCT
Join Date: Jan 2010
Location: Harrisburg, NC

Posts: 761
iTrader: (10)

I just had the same issue fixed. Severe rough idle when restarting the car and it was determined that all of the injectors needed to be replaced. No issues with idle once all injectors replaced. I would bet that this is your problem. My car was also at 40k.
Lambobimmer is online now   United_States
0
Reply With Quote
      11-20-2013, 07:13 AM   #16
raven333
Private First Class
 
raven333's Avatar
 
Drives: Sapphire Black 3.0siM sport
Join Date: Jun 2012
Location: United Kingdom

Posts: 175
iTrader: (0)

For those out of warranty I would seriously consider an injector and fuel system clean first, and not the cheap additives off the shelf, before I would run to the cost of replacing the very very expensive injectors..........in fact I would recommend doing this every 20-25k as a matter of maintenance!!!!!
raven333 is offline  
0
Reply With Quote
      11-20-2013, 09:45 AM   #17
Constant.S
Resistance is futile...
 
Constant.S's Avatar
 
Drives: BMW Z4 E89(N54) Porsche 997 4S
Join Date: Nov 2010
Location: Greece/Canada

Posts: 608
iTrader: (0)

Send a message via MSN to Constant.S Send a message via Skype™ to Constant.S
Quote:
Originally Posted by raven333 View Post
For those out of warranty I would seriously consider an injector and fuel system clean first, and not the cheap additives off the shelf, before I would run to the cost of replacing the very very expensive injectors..........in fact I would recommend doing this every 20-25k as a matter of maintenance!!!!!
What process do you recommend for injector cleaning if not the additives?
__________________
An ounce of performance is worth pounds of promises.
Constant.S is offline  
0
Reply With Quote
      11-20-2013, 03:10 PM   #18
nicknaz
Brigadier General
 
Drives: 2012 Z4 35i
Join Date: May 2008
Location: San Diego CA

Posts: 3,930
iTrader: (0)

Hey guys, back in the day I saw threads that discussed fuel quality as a factor in injector and HPFP failure.

Some posters got fuel where too much ethanol had been mixed, others were using fuel from random "non top tier" sources.

What kind of fuel are posters who are experiencing problems using?
nicknaz is offline   United_States
0
Reply With Quote
      11-20-2013, 03:43 PM   #19
Bob20124
Retired and Enjoying it
 
Bob20124's Avatar
 
Drives: 2011 Z4 35i Alpine White 6MT
Join Date: Jun 2013
Location: Northern VA

Posts: 57
iTrader: (0)

Shell or Sunoco
Bob20124 is offline   United_States
0
Reply With Quote
      11-20-2013, 04:56 PM   #20
jparnes1
Lieutenant Colonel
 
jparnes1's Avatar
 
Drives: 2006 525xi, 2012 Z4 35i
Join Date: Jan 2010
Location: Rochester, NY

Posts: 1,701
iTrader: (0)

Quote:
Originally Posted by nicknaz View Post
Hey guys, back in the day I saw threads that discussed fuel quality as a factor in injector and HPFP failure.

Some posters got fuel where too much ethanol had been mixed, others were using fuel from random "non top tier" sources.

What kind of fuel are posters who are experiencing problems using?
Was using Top Tier (Mobil) but recently switched to no-name, non-ethanol gas. I use Techron every 3-5K miles.
__________________
2012 Z4 35i, ED 2/24/2012, Melbourne Red Metallic, Black Leather, Carbon Trim, 6MT, ///M Sport, CW, PP, PS, NAV, CA, LED Angel Eyes, red calipers, pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side markers, Extra Enjoyment Package.
jparnes1 is online now   No_Country
0
Reply With Quote
      11-20-2013, 07:27 PM   #21
tranquility
sportscars only
 
tranquility's Avatar
 
Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Toronto

Posts: 1,458
iTrader: (0)

Quote:
Originally Posted by raven333 View Post
For those out of warranty I would seriously consider an injector and fuel system clean first, and not the cheap additives off the shelf, before I would run to the cost of replacing the very very expensive injectors..........in fact I would recommend doing this every 20-25k as a matter of maintenance!!!!!
What would you suggest? Off-the-shelf addictives won't help at all?


Quote:
Originally Posted by nicknaz View Post
Hey guys, back in the day I saw threads that discussed fuel quality as a factor in injector and HPFP failure.

Some posters got fuel where too much ethanol had been mixed, others were using fuel from random "non top tier" sources.

What kind of fuel are posters who are experiencing problems using?
I've only had rough start idle once and use 91 octane only.
tranquility is offline   Canada
0
Reply With Quote
      11-21-2013, 10:45 AM   #22
raven333
Private First Class
 
raven333's Avatar
 
Drives: Sapphire Black 3.0siM sport
Join Date: Jun 2012
Location: United Kingdom

Posts: 175
iTrader: (0)

I am not saying that additives are not to be used, just not the cheap ones, they do very little. One additive I use consistently is BG44k, it is not cheap (here in the UK) but really does work in cleaning the fuel system. Outside of this garages offer an fuel system clean, with specialist equipment for about $100 ??????. I have had feedback to say that people have had excellent results....... like most things everyone has an opinion !!!!! I have used this for the last number of years on all my cars.......it made a big difference when I did it on my 6 series for the first time!!!
raven333 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:54 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST