New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      12-17-2012, 03:56 PM   #1
GentleWen
Private
 
Drives: 2013 Z4 35i
Join Date: Nov 2012
Location: United States

Posts: 75
iTrader: (0)

[updated!! successful!!]smart Top: Lost faith.. what do I do now...

Here's some update since last my SmartTop installation hazard..(see here:http://e89.zpost.com/forums/showthread.php?t=781671)

Just got back from the dealer, turn out the reason is only.. "loose". see pic..

But after this.. I kinda lost faith to install it my self....
afraid of getting into the same situation again...
what do i do now ....

-------------------------- 12/19 update -------------
So I gave it another shot today, and the first time the same issue happened again. although I'm pretty sure I make the connector "go all the way in" --- except not so hard that I might accidentally break anything ..

but this time I didn't panic go back and press it really hard again!
and I hear a beautiful "click" and the light flashes!

I know it should work now!!! and it did!!!! YYYYYAAAAAAAAAAAA!!!!!!!!
so for everyone is going to install the smartTop module, do press REALLY HARD!!!


so I tested the functions, all works as programmed except one small issue:
the hardtop controller/button in the car are functionally reversed!!
dont know how that happened, if anyone can tell me how to fixed that would be nice(perfectionism ) if not.. i'll just have to bare with it ...

and btw, the modules seems to erased my stored settings, like seat position, programmable buttons, that's normal right ?
Attached Images
 

Last edited by GentleWen; 12-19-2012 at 09:57 AM.
GentleWen is offline  
0
Reply With Quote
      12-17-2012, 04:01 PM   #2
rking117
Captain
 
Drives: Z4 3.0i & 320i
Join Date: Aug 2012
Location: Central Florida

Posts: 996
iTrader: (0)

you can do it but youll have to dbl check everything and take your time. of course you could always pay an indy shop to install.
__________________
Enjoying an E89 Z4, F30 320i and Fiat Pop 500 //
E85 Z4 (sold), E82 128i (sold)
rking117 is offline  
0
Reply With Quote
      12-17-2012, 04:06 PM   #3
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,261
iTrader: (0)

Send a message via MSN to ManiacGT
Lucky escape if you ask me... 'connector half off from factory' yeah right. Amazed they believed that and not that you'd been 'fiddling'...

I know of no one that has had an issue with the smart top unless they didnt install it correctly.
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      12-17-2012, 05:29 PM   #4
morfinx
Shenanigans
 
morfinx's Avatar
 
Drives: E89 Z4 sDrive35i
Join Date: Jul 2010
Location: Austin, TX

Posts: 1,222
iTrader: (0)

Could always have a shop do it if you don't want to deal with it.
__________________
E89 Z4 sDrive35i 7DCT "Zayna", Alpine White/Coral Red
E92 335i 6MT "Calixta", Space Grey/Coral Red [Retired]

morfinx is offline   United_States
0
Reply With Quote
      12-17-2012, 06:53 PM   #5
Mayhem
Private First Class
 
Drives: 2012 Z4 sDrive35is
Join Date: Jan 2012
Location: Hollywood

Posts: 173
iTrader: (0)

It's not that hard to install. Fifteen minute job. At least now, if it happens again, you know what the issue is, and you can just push the connector together. I gather you're not mechanically inclined?
Mayhem is offline  
0
Reply With Quote
      12-17-2012, 07:10 PM   #6
lcheong
New Member
 
Drives: 2011 Black Sapphire 30i Z4, Bl
Join Date: May 2012
Location: Marin County, CA

Posts: 22
iTrader: (0)

As others have written above ... when you attach that connector, you have to REALLY be sure that it is fully seated. This is true for when you attach the connector WITH or WITHOUT the SmartTop.

I know now what it feels like to have it fully seated. It goes "all the way in". When it is not fully seated, it does not go all the way in, but it feels like it might be right.

Also, at least for my car, when it goes all the way in, I see the lights blinking, and I hear a few clicks. That's how I know that it is working.
lcheong is offline  
0
Reply With Quote
      12-17-2012, 08:07 PM   #7
nicknaz
Brigadier General
 
Drives: 2012 Z4 35i
Join Date: May 2008
Location: San Diego CA

Posts: 3,928
iTrader: (0)

I guess it all depends on how badly you want to open the roof while the car is moving? (or whatever benefit that thing was supposed to have)

I never thought that part was worth it so I personally would return the part and move on to something else.
nicknaz is offline   United_States
0
Reply With Quote
      12-17-2012, 08:41 PM   #8
BuckarooVT90
Private First Class
 
BuckarooVT90's Avatar
 
Drives: '13 Z4 sDrive35i DCT
Join Date: Sep 2010
Location: Virginia

Posts: 188
iTrader: (1)

Garage List
2013 Z4 Sdrive35i  [0.00]
2011 135i  [0.00]
Just like I said.... You didn't correctly and securely make the connections to the harness and module...
BuckarooVT90 is offline   United_States
0
Reply With Quote
      12-17-2012, 10:33 PM   #9
GentleWen
Private
 
Drives: 2013 Z4 35i
Join Date: Nov 2012
Location: United States

Posts: 75
iTrader: (0)

It's not only opening the top...(actually new z4 can open top up to 25mph by default.)
there're quite some convenient changes like:
unlock the door/fold mirrors automatically when you stop/start engine.
unlock both side doors when you put your hand under the handle.
etc etc..
these're all program setting, no idea why BMW made them so stupid by default.


Quote:
Originally Posted by nicknaz View Post
I guess it all depends on how badly you want to open the roof while the car is moving? (or whatever benefit that thing was supposed to have)

I never thought that part was worth it so I personally would return the part and move on to something else.
GentleWen is offline  
0
Reply With Quote
      12-17-2012, 10:43 PM   #10
morfinx
Shenanigans
 
morfinx's Avatar
 
Drives: E89 Z4 sDrive35i
Join Date: Jul 2010
Location: Austin, TX

Posts: 1,222
iTrader: (0)

Quote:
Originally Posted by GentleWen View Post
It's not only opening the top...(actually new z4 can open top up to 25mph by default.)
there're quite some convenient changes like:
unlock the door/fold mirrors automatically when you stop/start engine.
unlock both side doors when you put your hand under the handle.
etc etc..
these're all program setting, no idea why BMW made them so stupid by default.
Most of those things can be coded if you have comfort access. Some of them can be coded even if you don't have CA. I don't have CA and I can fold/unfold mirrors with my fob.
__________________
E89 Z4 sDrive35i 7DCT "Zayna", Alpine White/Coral Red
E92 335i 6MT "Calixta", Space Grey/Coral Red [Retired]

morfinx is offline   United_States
0
Reply With Quote
      12-17-2012, 10:55 PM   #11
GentleWen
Private
 
Drives: 2013 Z4 35i
Join Date: Nov 2012
Location: United States

Posts: 75
iTrader: (0)

I do have comfort access. how can I code it ?
Quote:
Originally Posted by morfinx View Post
Most of those things can be coded if you have comfort access. Some of them can be coded even if you don't have CA. I don't have CA and I can fold/unfold mirrors with my fob.
GentleWen is offline  
0
Reply With Quote
      12-17-2012, 11:11 PM   #12
morfinx
Shenanigans
 
morfinx's Avatar
 
Drives: E89 Z4 sDrive35i
Join Date: Jul 2010
Location: Austin, TX

Posts: 1,222
iTrader: (0)

Quote:
Originally Posted by GentleWen View Post
I do have comfort access. how can I code it ?
You need to find someone with the right data cable, or you can buy one for about $100. The software is free, but the procedures are pretty archaic and unintuitive. You will also need a laptop running Windows. There is a coding section on e90post. There is also a BMW coding forum. That's basically where the coding knowledge is collectively accumulated. There is no manual for this. I don't know how personally (nor do I have the right equipment to do it), but I had a friend who is local do it for me. He did my E92 335i and I was able to raise/lower my window, close/open sunroof, and fold/unfold mirrors with my keyfob. We had a much harder time with my Z4 for some reason, and we suspect it's because I don't have CA (the 335i didn't either though). So far we've only been able to get the remote mirror folding/unfolding working. But that's all I really wanted (I don't need/want remote top).

I think the remote window/top is part of CA though, according to the manual:
Attached Images
 
__________________
E89 Z4 sDrive35i 7DCT "Zayna", Alpine White/Coral Red
E92 335i 6MT "Calixta", Space Grey/Coral Red [Retired]

morfinx is offline   United_States
0
Reply With Quote
      12-17-2012, 11:12 PM   #13
snk
Lieutenant
 
snk's Avatar
 
Drives: 2011 Z4
Join Date: May 2011
Location: NorCal

Posts: 470
iTrader: (1)

you can code on your own (not recommended if you don't know what you're doing)
http://www.e90post.com/forums/showthread.php?t=480261

or find someone local that can do it for you, most likely for a small fee.
Here's an example of a local shop for coding
http://www.e90post.com/forums/showthread.php?t=534142
snk is offline   United_States
0
Reply With Quote
      12-18-2012, 12:48 AM   #14
BuckarooVT90
Private First Class
 
BuckarooVT90's Avatar
 
Drives: '13 Z4 sDrive35i DCT
Join Date: Sep 2010
Location: Virginia

Posts: 188
iTrader: (1)

Garage List
2013 Z4 Sdrive35i  [0.00]
2011 135i  [0.00]
If you we're close by I'd install it for your for free... Or at least a beer or two. You got the module already... You don't need to mess with coding...
BuckarooVT90 is offline   United_States
0
Reply With Quote
      12-19-2012, 12:57 AM   #15
GentleWen
Private
 
Drives: 2013 Z4 35i
Join Date: Nov 2012
Location: United States

Posts: 75
iTrader: (0)

thx all...
I'll give it another try tomorrow...
finger crossed...
GentleWen is offline  
0
Reply With Quote
      12-19-2012, 01:08 AM   #16
Hoa
Lieutenant
 
Drives: BMW
Join Date: May 2010
Location: GA

Posts: 532
iTrader: (8)

just take your time. push it all the way in and then latch the harness. you should be fine
Hoa is offline   United_States
0
Reply With Quote
      12-19-2012, 09:57 AM   #17
GentleWen
Private
 
Drives: 2013 Z4 35i
Join Date: Nov 2012
Location: United States

Posts: 75
iTrader: (0)

So I gave it another shot today, and the first time the same issue happened again. although I'm pretty sure I make the connector "go all the way in" --- except not so hard that I might accidentally break anything ..

but this time I didn't panic go back and press it really hard again!
and I hear a beautiful "click" and the light flashes!

I know it should work now!!! and it did!!!! YYYYYAAAAAAAAAAAA!!!!!!!!
so for everyone is going to install the smartTop module, do press REALLY HARD!!!


so I tested the functions, all works as programmed except one small issue:
the hardtop controller/button in the car are functionally reversed!!
dont know how that happened, if anyone can tell me how to fixed that would be nice(perfectionism ) if not.. i'll just have to bare with it ...

and btw, the modules seems to erased my stored settings, like seat position, programmable buttons, that's normal right ?
GentleWen is offline  
0
Reply With Quote
      12-19-2012, 11:55 AM   #18
Mayhem
Private First Class
 
Drives: 2012 Z4 sDrive35is
Join Date: Jan 2012
Location: Hollywood

Posts: 173
iTrader: (0)

Quote:
Originally Posted by GentleWen View Post

so I tested the functions, all works as programmed except one small issue:
the hardtop controller/button in the car are functionally reversed!!
dont know how that happened, if anyone can tell me how to fixed that would be nice(perfectionism ) if not.. i'll just have to bare with it ...

and btw, the modules seems to erased my stored settings, like seat position, programmable buttons, that's normal right ?
I believe this is a toggle setting in the programming.
Mayhem is offline  
0
Reply With Quote
      12-19-2012, 12:08 PM   #19
morfinx
Shenanigans
 
morfinx's Avatar
 
Drives: E89 Z4 sDrive35i
Join Date: Jul 2010
Location: Austin, TX

Posts: 1,222
iTrader: (0)

This is a triumph! I'm making a note here:

HUGE SUCCESS!!
__________________
E89 Z4 sDrive35i 7DCT "Zayna", Alpine White/Coral Red
E92 335i 6MT "Calixta", Space Grey/Coral Red [Retired]

morfinx is offline   United_States
0
Reply With Quote
      12-19-2012, 04:30 PM   #20
BuckarooVT90
Private First Class
 
BuckarooVT90's Avatar
 
Drives: '13 Z4 sDrive35i DCT
Join Date: Sep 2010
Location: Virginia

Posts: 188
iTrader: (1)

Garage List
2013 Z4 Sdrive35i  [0.00]
2011 135i  [0.00]
grats... glad you finally got it working correctly.... there is a reverse button option that you can turn on or off... its specifically for the 3series button since its a single Toggle button that you pull or push (much like our window switches), unlike our two separate buttons. Sort of wish our buttons were like that and were beside the shifter like it was in our previous E46 convertible...closer and easier to reach.
BuckarooVT90 is offline   United_States
0
Reply With Quote
      12-19-2012, 04:43 PM   #21
GentleWen
Private
 
Drives: 2013 Z4 35i
Join Date: Nov 2012
Location: United States

Posts: 75
iTrader: (0)

Thanks man, is this "reverse button option that you can turn on or off" is defined in the smartTop module or the car?

Quote:
Originally Posted by BuckarooVT90 View Post
grats... glad you finally got it working correctly.... there is a reverse button option that you can turn on or off... its specifically for the 3series button since its a single Toggle button that you pull or push (much like our window switches), unlike our two separate buttons. Sort of wish our buttons were like that and were beside the shifter like it was in our previous E46 convertible...closer and easier to reach.
GentleWen is offline  
0
Reply With Quote
      12-20-2012, 09:14 AM   #22
BuckarooVT90
Private First Class
 
BuckarooVT90's Avatar
 
Drives: '13 Z4 sDrive35i DCT
Join Date: Sep 2010
Location: Virginia

Posts: 188
iTrader: (1)

Garage List
2013 Z4 Sdrive35i  [0.00]
2011 135i  [0.00]
function #8.... what did you set that to? It should be OFF... you probably set it to ON that's why your switches are reversed.
BuckarooVT90 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:27 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST