New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      06-20-2021, 10:12 AM   #1
DieDane
Registered
Denmark
0
Rep
2
Posts

Drives: BMW Z4 2010
Join Date: Jun 2021
Location: Danmark

iTrader: (0)

Trunk/Kofferraum drain

Hi All, hope someone can answer this question.

I realized that I had a lot a water in the trunk and that the foam supporting the hydralic pump was soaked. I removed the foam to dry everything. Under the hydralic pump and the foam, there is some sort of drainage hose (the gray one). Should that hose be connected to something? Name:  2021-06-20 12.55.57.jpg
Views: 113
Size:  388.6 KB
Appreciate 0
      06-20-2021, 10:57 AM   #2
DavesZed
Second Lieutenant
United Kingdom
59
Rep
275
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

That pipe normally has a 90 degree end on it that connects into the side of the battery as a drain away (if required). Looks like the battery has been changed to one that either didn't need it or they left the elbow on the old one and didn't realise.
Appreciate 0
      06-20-2021, 11:55 PM   #3
DieDane
Registered
Denmark
0
Rep
2
Posts

Drives: BMW Z4 2010
Join Date: Jun 2021
Location: Danmark

iTrader: (0)

Thanks... Shouldn't there be some sort of drain hole somewhere? I mean any water in the trunk will end up in that battery/hydralic pump bay.
Appreciate 0
      06-22-2021, 01:14 AM   #4
Sergiu
New Member
Romania
0
Rep
12
Posts

Drives: 2016 Z4 28i, 2014 520D
Join Date: Mar 2021
Location: Romania

iTrader: (0)

There doesn't seem to be any drain hole at all. I once had about 4 liters of windscreen washer fluid leak from a bag and the only solution was to pump it out.
Appreciate 0
      06-22-2021, 03:03 PM   #5
bigendbob
Private First Class
United Kingdom
17
Rep
185
Posts

Drives: z4 23i Orion Silver
Join Date: Jun 2012
Location: west midlands

iTrader: (0)

Lack of drain hole is not the problem
Water getting in when it shouldn't is the problem.
Appreciate 0
      06-23-2021, 08:28 AM   #6
RobbiZ4
Call me "Dr. Bob"
RobbiZ4's Avatar
Germany
37
Rep
156
Posts

Drives: BMW Z4 E89 sDrive 30i
Join Date: Jan 2018
Location: Munich, Bavaria (Home of BMW)

iTrader: (0)

Quote:
Originally Posted by DavesZed View Post
That pipe normally has a 90 degree end on it that connects into the side of the battery as a drain away (if required). Looks like the battery has been changed to one that either didn't need it or they left the elbow on the old one and didn't realise.
Correct. Even this replaced VARTA battery has a drain hole.
__________________
Appreciate 0
      06-24-2021, 05:01 AM   #7
Sergiu
New Member
Romania
0
Rep
12
Posts

Drives: 2016 Z4 28i, 2014 520D
Join Date: Mar 2021
Location: Romania

iTrader: (0)

Quote:
Originally Posted by bigendbob View Post
Lack of drain hole is not the problem
Water getting in when it shouldn't is the problem.
Accidents happen, why not make sure the damage is minimal? It would have costed almost nothing to make a drain in the trunk.
Appreciate 0
      07-09-2021, 06:48 AM   #8
Mayhem
Second Lieutenant
20
Rep
243
Posts

Drives: 2012 Z4 sDrive35is
Join Date: Jan 2012
Location: Hollywood

iTrader: (0)

You’ve discovered one of the frustrations of owning a Z4. The trunks often leak when it rains. If you aren’t careful, the water will accumulate in the recessed area and eventually ruin your roof’s hydraulic top. I learned this the hard way after having a roof failure and had to have my hydraulic motor repaired. I suggest you keep an eye on water incursion if your car is left in the rain.
Appreciate 0
      07-10-2021, 09:18 AM   #9
Sergiu
New Member
Romania
0
Rep
12
Posts

Drives: 2016 Z4 28i, 2014 520D
Join Date: Mar 2021
Location: Romania

iTrader: (0)

Is drilling a hole somewhere in the recessed area that houses the battery and the hydraulic motor an option? Can it drain out without causing any harm? Just a question, looks like a very easy fix and I'm wondering if anyone has tried it.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:35 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST