New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      06-13-2014, 04:32 PM   #1
MarkVLK
New Member
2
Rep
12
Posts

Drives: 2009 E89 BMW Z4 sDrive30i
Join Date: Sep 2013
Location: San Jose, CA

iTrader: (0)

Trunk won't seal all the way shut, can't operate hard top

I've been dealing with this trunk issue on my 2009 BMW Z4 (E89) for about two months now, wondering if any of you have any insight.

When I close the trunk, it latches (won't open back up without pushing trunk release button) but it doesn't seal shut the remaining centimeter or so like it's supposed to. Because of this, the car thinks the trunk is still open which restricts me from operating the hard top.

It seems to work (seal shut) intermittently and sometimes even while I'm driving or when I close my car door, but 90% of the time it doesn't work. BMW quoted me $891.27 for "the entire rear trunk lock and mechanism" + labor. Anyone know specifically what the issue may be and if there's a cheaper way for me to get it fixed?
Appreciate 0
      06-13-2014, 05:07 PM   #2
tranquility
sportscars only
tranquility's Avatar
Canada
213
Rep
2,066
Posts

Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Montrťal

iTrader: (0)

That's weird, they quoted you for the repair but didn't tell you the cause?
Appreciate 0
      06-13-2014, 06:09 PM   #3
MarkVLK
New Member
2
Rep
12
Posts

Drives: 2009 E89 BMW Z4 sDrive30i
Join Date: Sep 2013
Location: San Jose, CA

iTrader: (0)

Yeah, they wouldn't even tell me the specific part name or number beyond what I wrote above :/ and one of the service advisers told me that they've never seen this issue before but then one of the younger guys that comes up and asks you why you're visiting the dealership today, etc. said he's actually seen this same issue a few times... Love dealerships.
Appreciate 0
      06-13-2014, 06:39 PM   #4
nicknaz
Major General
nicknaz's Avatar
United_States
2559
Rep
9,769
Posts

Drives: 6TT, model 3P, SM, F31 330
Join Date: May 2008
Location: NorCal

iTrader: (0)

OP, my GUESS is that part that needs replacing is the $461 "latch" shown below as part #10

good luck

http://www.getbmwparts.com/parts/201...gramCallOut=10
Appreciate 0
      06-13-2014, 09:23 PM   #5
MarkVLK
New Member
2
Rep
12
Posts

Drives: 2009 E89 BMW Z4 sDrive30i
Join Date: Sep 2013
Location: San Jose, CA

iTrader: (0)

Thanks for the link, nicknaz.

I tried calling a different dealership and describing the problem in an attempt to find out what part they think may need replacement and they said the part would cost about $683 if I recall correctly. Given that the part you referenced is the most expensive part of the trunk on that link (besides the lid itself), it's possible that this is the correct part but I'm worried I'll buy the wrong part :O
Appreciate 0
      06-13-2014, 10:51 PM   #6
nicknaz
Major General
nicknaz's Avatar
United_States
2559
Rep
9,769
Posts

Drives: 6TT, model 3P, SM, F31 330
Join Date: May 2008
Location: NorCal

iTrader: (0)

How about just referencing the discount being given by that website and ask they price match?

My local dealer beat the price for "m power kit" for F30
Appreciate 0
      06-16-2014, 01:47 PM   #7
MarkVLK
New Member
2
Rep
12
Posts

Drives: 2009 E89 BMW Z4 sDrive30i
Join Date: Sep 2013
Location: San Jose, CA

iTrader: (0)

I might give that a shot! Thanks for the tip!
Appreciate 0
      06-17-2014, 02:50 PM   #8
bigendbob
Private First Class
United Kingdom
15
Rep
164
Posts

Drives: z4 23i Orion Silver
Join Date: Jun 2012
Location: west midlands

iTrader: (0)

Before you go spending lots of money, just take off the boot trim and have a look. I did this some time ago. The mechanism is not complicated and you might find a easier solution than just replacing parts.
Something might need a minor adjustment.
I was so fascinated by the mechanism I recorded it on my mobile phone. If I can find will upload to youtube for comparison.

Found;


Might be of some use. Each end are the draw down gearboxes and motors.
The white lever has a extra hole for a manual boot release, but its not fitted.

I was contemplating fitting a manual boot release or cheap door solenoid operated by a cabin switch, in case it ever got stuck.

Last edited by bigendbob; 06-17-2014 at 03:07 PM..
Appreciate 0
      06-26-2014, 06:26 PM   #9
MarkVLK
New Member
2
Rep
12
Posts

Drives: 2009 E89 BMW Z4 sDrive30i
Join Date: Sep 2013
Location: San Jose, CA

iTrader: (0)

Thanks for the video and info! If I get a chance, I might try to take a look tonight and see if anything stands out. I was gone for the better half of the last week so haven't had a chance to look at it yet, but here's to hoping I can fix it myself and not spend $900 just so that the trunk will seal that final centimeter :|
Appreciate 0
      11-19-2014, 05:08 PM   #10
BugsBunny
Private First Class
United_States
11
Rep
117
Posts

Drives: 2009 Z4 3.5i, 2015 BMW X3 2.8i
Join Date: Dec 2010
Location: Houston, Texas

iTrader: (0)

Quote:
Originally Posted by MarkVLK View Post
but here's to hoping I can fix it myself and not spend $900 just so that the trunk will seal that final centimeter :|
MarkVLK - any news on this ? It seems that I am facing the same issue
Appreciate 0
      01-01-2015, 01:49 PM   #11
BugsBunny
Private First Class
United_States
11
Rep
117
Posts

Drives: 2009 Z4 3.5i, 2015 BMW X3 2.8i
Join Date: Dec 2010
Location: Houston, Texas

iTrader: (0)

Bump !
Appreciate 0
      01-22-2015, 02:47 PM   #12
BugsBunny
Private First Class
United_States
11
Rep
117
Posts

Drives: 2009 Z4 3.5i, 2015 BMW X3 2.8i
Join Date: Dec 2010
Location: Houston, Texas

iTrader: (0)

Issue solved.
For your info and reference:
The issue was linked to the SmartTop module which failed (after 4 years of loyal service, 2-4 times a day).
Before going to the dealership in order to complain about the electric assist motor not working anymore and the impossibility to fully close the trunk, I tried to disable the SmartTop module (always disable SmartTop before going to the dealership). Strange enough I couldn't connect my PC to the module via the USB cable.
2 electrical failures at the same time ? Nah, I don't believe in such coincidence.
So I emailed SmartTop support and they indeed confirmed that a total module failure could impact the electric trunk closure. They then quickly diagnosed the issue with the module. They shipped me a new one for free. I installed it and voila, the eletric assist motor could close the trunk
Appreciate 0
      01-23-2015, 02:37 AM   #13
Mick70
Private First Class
9
Rep
158
Posts

Drives: Z4 sdrive35i (before: 23i)
Join Date: Nov 2009
Location: Germany

iTrader: (0)

Good solution.

As I am increasingly encountering similar problems with a (different kind of) roof module, how could you install the new module without fully closing the trunk? As soon as my module stops working intermittently, I cannot do anything with the roof - so I could not even open it to "half position" (http://bit.ly/1CqOx04) to get access to the module

Best regards

Mick
Appreciate 0
      01-23-2015, 11:39 AM   #14
BugsBunny
Private First Class
United_States
11
Rep
117
Posts

Drives: 2009 Z4 3.5i, 2015 BMW X3 2.8i
Join Date: Dec 2010
Location: Houston, Texas

iTrader: (0)

Quote:
Originally Posted by Mick70 View Post
how could you install the new module without fully closing the trunk?
I think we are facing different issues. The SmartTop module can be accessed directly from the trunk without the need to put the roof in Maintenance Mode (as your picture shows). I just removed some liners in the trunk.

And probably to answer your implicit question , yes indeed, until I received the new module, I was driving without the trunk fully closed ... but my commute is only 2 miles (3.2km)
Appreciate 0
      07-12-2019, 03:40 AM   #15
Hosse
Enlisted Member
Hosse's Avatar
1
Rep
33
Posts

Drives: BMW Z4 E89 2009
Join Date: Sep 2014
Location: Norway

iTrader: (0)

I know this is an old post, but Iíll try anyway.

Today I also got this problem with my trunk. Did anyone find a solution for this? I donít have any retrofitted module for the top. All is OEM.
Appreciate 0
      07-12-2019, 02:01 PM   #16
BugsBunny
Private First Class
United_States
11
Rep
117
Posts

Drives: 2009 Z4 3.5i, 2015 BMW X3 2.8i
Join Date: Dec 2010
Location: Houston, Texas

iTrader: (0)

Quote:
Originally Posted by Hosse View Post
I know this is an old post, but I’ll try anyway.

Today I also got this problem with my trunk. Did anyone find a solution for this? I don’t have any retrofitted module for the top. All is OEM.
Have you checked your battery ? Is it a new one ?
Appreciate 0
      08-05-2019, 04:34 AM   #17
Hosse
Enlisted Member
Hosse's Avatar
1
Rep
33
Posts

Drives: BMW Z4 E89 2009
Join Date: Sep 2014
Location: Norway

iTrader: (0)

I fixed it yesterday! One cable to the left micro switch was broken:-)
Appreciate 0
Post Reply

Bookmarks

Tags
close, issue, problem, seal, trunk

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:11 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST