New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      12-07-2018, 05:14 PM   #1
tranquility
sportscars only
tranquility's Avatar
Canada
250
Rep
2,108
Posts

Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Montréal

iTrader: (0)

@@@HELP: Newly-replaced battery issues!!!@@@

Anyone experience prbs after changing their battery? Not sure if coincidence but afterwards the trunk light failed to work. Supposedly, the tech said it was not related, so they performed further diagnostics since a new bulb didn't work, suggesting some cable link breakage. After accessing the area underneath the trunk lid, they said that something inside was defective and hence caused the bulb light malfunction. It also now caused the trunk to not fully close, i.e. you know that motor noise one hears to seal the remaining small gap after the lid is closed? It no longer does that. So now instead of having the lightbulb issue fixed, I now have an ADDITIONAL prb of a failed latch!

Who do you think should be responsible for the light and now failed latch prbs? Apparently, a new whole console (because the BMW engineers are 'geniuses' and I can't just replace the broken part) costs well over CAD1,100! At first they wanted to disavow any responsibility, saying the console was defective anyway, that's why the bulb died, and it's proven because the latch doesn't work now, since the console controls both functions. To me, it doesn't make sense, I'm just going to take their word for it? All I know is that the latch was fine when I went for service and only the bulb wasn't working. In any event, shouldn't they be careful taking apart my car and be liable for any damage? They make it sound like the console was already fragile and just because the tech had to access it, it's not their fault the latch now doesn't work. Doesn't sound fair or reasonable to me.

Please help if you have any advice. TIA. Work done at BMW dealer.

Last edited by tranquility; 12-07-2018 at 05:35 PM..
Appreciate 0
      12-08-2018, 05:48 PM   #2
Eltee
Private First Class
United_States
14
Rep
150
Posts

Drives: 2011 Z4 35i
Join Date: Mar 2012
Location: Milwaukee, WI

iTrader: (0)

If something was working when you brought it into the shop and now it isn't, in my opinion they are completely responsible. No different than if they took your dash apart and now they can't put it back together because they broke some parts. Or they ripped a hole in your seat, or they broke the turn signal stalk because it was brittle being 7 years old.

I'd push it to the hilt. You shouldn't be responsible for any charge. They took your car in and screwed something up, it's up to them to fix it.
Appreciate 1
      12-08-2018, 05:51 PM   #3
Eltee
Private First Class
United_States
14
Rep
150
Posts

Drives: 2011 Z4 35i
Join Date: Mar 2012
Location: Milwaukee, WI

iTrader: (0)

And if the dealer does not make you whole, I'd escalate it up the ladder to the district manager.
Appreciate 1
      12-08-2018, 07:50 PM   #4
tranquility
sportscars only
tranquility's Avatar
Canada
250
Rep
2,108
Posts

Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Montréal

iTrader: (0)

Tx, I'm just disappointed that the first knee-jerk reaction is to deny, deny deny.

Unfortunately for me, no one experienced any electronic gremlin issues after their battery was changed? I'm just wondering how come the interior trunk light suddenly stopped working.
Appreciate 0
      03-23-2020, 01:06 PM   #5
Xpuzzle
Private
United_States
5
Rep
62
Posts

Drives: 2006 325i, 2011 Z4 35i
Join Date: Jul 2011
Location: Chicagoland

iTrader: (0)

Tranquility - did you ever figure out what the root cause was?

I have been experiencing the same issues with my 2011 35i. Trunk won't latch close and light is off. A bunch of error icons show up in the dash. It happens intermittently but they eventually fix themselves after a few minutes.
Appreciate 0
      03-24-2020, 05:07 AM   #6
RobbiZ4
Call me "Dr. Bob"
RobbiZ4's Avatar
Germany
30
Rep
135
Posts

Drives: BMW Z4 E89 sDrive 30i
Join Date: Jan 2018
Location: Munich, Bavaria (Home of BMW)

iTrader: (0)

Quote:
Originally Posted by Xpuzzle View Post
Tranquility - did you ever figure out what the root cause was?

I have been experiencing the same issues with my 2011 35i. Trunk won't latch close and light is off. A bunch of error icons show up in the dash. It happens intermittently but they eventually fix themselves after a few minutes.
There are broken wires in the locking system of the trunc lid, mostly on the left side.
The microswitch, that controls the locking motor on the left, is also responsible for the trunc light.

Have a look at the pictures of the following thread:
https://translate.google.com/transla...23post-2971955
Appreciate 0
      03-24-2020, 05:45 PM   #7
tranquility
sportscars only
tranquility's Avatar
Canada
250
Rep
2,108
Posts

Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Montréal

iTrader: (0)

Quote:
Originally Posted by Xpuzzle View Post
Tranquility - did you ever figure out what the root cause was?

I have been experiencing the same issues with my 2011 35i. Trunk won't latch close and light is off. A bunch of error icons show up in the dash. It happens intermittently but they eventually fix themselves after a few minutes.
Ah, I had to reread my thread, what a nightmare that was...!

In short, I don't think we have the same prb. I think yours is something to do w faulty wiring/electrical issues...mine was that, but the cause was the doofus tech that caused it when replacing my battery (car was perfect before I had my battery changed). They were adamant refusing responsibility initially but I made them eat it and fix everything in the end. Just disappointed they didn't 'fess up right away that the tech screwed up, it was pretty obvious.

Anyway, GL w your troubles and hope it gets sorted.
Appreciate 0
      03-25-2020, 08:39 AM   #8
scootr
Private
scootr's Avatar
United_States
98
Rep
73
Posts

Drives: E89 Z4 3.0 6MT
Join Date: Sep 2019
Location: Southern California

iTrader: (0)

Quote:
Originally Posted by tranquility View Post
Ah, I had to reread my thread, what a nightmare that was...!

In short, I don't think we have the same prb. I think yours is something to do w faulty wiring/electrical issues...mine was that, but the cause was the doofus tech that caused it when replacing my battery (car was perfect before I had my battery changed). They were adamant refusing responsibility initially but I made them eat it and fix everything in the end. Just disappointed they didn't 'fess up right away that the tech screwed up, it was pretty obvious.

Anyway, GL w your troubles and hope it gets sorted.
Glad you won. Sorry you had to go through this but, in your case, it seemed obvious the tech was a gorilla with a heavy battery in and out of the trunk which caused the damage.
Appreciate 0
      03-25-2020, 09:01 PM   #9
tranquility
sportscars only
tranquility's Avatar
Canada
250
Rep
2,108
Posts

Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Montréal

iTrader: (0)

Quote:
Originally Posted by scootr View Post
Glad you won. Sorry you had to go through this but, in your case, it seemed obvious the tech was a gorilla with a heavy battery in and out of the trunk which caused the damage.
Ya, but I always try to give the benefit of doubt, hear them out first, so when they first changed the battery and the trunk light didn't work right after, I thought ok, maybe my light just coincidentally burnt so I'll have them check/replace said light...little did I know it opened a whole new can....more like a shipping container LOL...of worms as the tech not only didn't fix the light but somehow messed up the wiring w/i the trunk lid so that my trunk now didn't close properly as well! The $10M question is what the heck was he doing up there??? As we all know, the freaking battery's in the floorwell and from my layman view, it's a simple unplug job and doing the recoding. I asked the SA who got things sorted for me in the end just what the heck happened and he shook his head and said "don't ask, don't ask, we'll get it fixed, end of story"...so talk about some major MAJOR bumbling there lol...holy moly...I can't even lmao....

It was so frustrating/upsetting during that time (rarely have I ever gotten so angry in my life!), as I was potentially looking at a ~$1,700? bill to get everything fixed for something clearly not my fault, but I was somehow in BMW DEALER BIZARRO WORLD so they were STRONGLY denying fault and wanting me to hold the bag! Their excuse was the wiring was already faulty, so when they opened the panels, POOF, shorted, so not their fault...like I set a booby trap for them? I can't really make sense of their weakX 'argument'. Utter rubbish and illogical, maybe something a 3 year old would make up to try to not get into trouble. Anyway...

Looking back now I can finally have a laugh and probably made some of you guys chuckle. NO IDEA how the tech could screw up SO BADLY! It's a freaking reg battery job, I'm not telling him to do an engine swap and put the Veyron's W16 in there SMHLOL.
Appreciate 0
      03-28-2020, 08:10 AM   #10
Xpuzzle
Private
United_States
5
Rep
62
Posts

Drives: 2006 325i, 2011 Z4 35i
Join Date: Jul 2011
Location: Chicagoland

iTrader: (0)

Thank you RobbiZ4 and Tranquility for your responses.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:31 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST