New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      12-05-2018, 08:00 AM   #1
Dusty78
New Member
15
Rep
22
Posts

Drives: 2012 Z4 28i
Join Date: Sep 2018
Location: Charlotte NC

iTrader: (0)

So it's been a long journey but I finally got a new system in my E89 premium sound non-iDrive car. BMW sure doesn't make it easy. The previous thread with the Joying radio got the ball rolling. I ordered the harness and adapters from Germany but they didn't work. The Z uses fiber optic cable instead of speaker wire. The Germans then directed me to buy a $250 fiber optic adapter that still didn't work. $420 later I was still going nowhere. Eventually I just decided to scrap the factory amp and got a new JL Audio amp that sounds 100x better.

I decided to go with the Pioneer 3400NEX. It is a flip out unit that fits in the single DIN bay. When flipped out it does obscure the AC controls but there's a button that you push to temporarily flip the screen to access them. You can see it in the video. The steering wheel controls all work except for the AC recirc button. I wish it could be programmed to activate that temporary screen flip button. CarPlay works flawlessly and the backup camera is very helpful. I initially wanted to get the Alpine Halo but the fit just wouldn't work well do to the size. So far I'm very happy with the setup.

https://www.youtube.com/embed/K4usy6G7sog
Attached Images
    
Appreciate 0
      12-05-2018, 10:55 AM   #2
tommylotto
Enlisted Member
United_States
0
Rep
35
Posts

Drives: 2015 BMW Z4 sDrive28i
Join Date: Jun 2018
Location: Laguna Hills, CA

iTrader: (0)

Good job. Youíre backup camera looks a lot better than mine. Mine is angled too far down. However the systems we cobbled together (like my Joying) look like they are going to be blown away by a new AVIN USA unit custom designed for the e89. They claim it will be release sometime this month.
Appreciate 0
      12-05-2018, 11:49 AM   #3
Dusty78
New Member
15
Rep
22
Posts

Drives: 2012 Z4 28i
Join Date: Sep 2018
Location: Charlotte NC

iTrader: (0)

Quote:
Originally Posted by tommylotto View Post
Good job. You're backup camera looks a lot better than mine. Mine is angled too far down. However the systems we cobbled together (like my Joying) look like they are going to be blown away by a new AVIN USA unit custom designed for the e89. They claim it will be release sometime this month.
Yeah I know. The good thing is that I can always go back to the original head unit with my new amp and add the AVIN. I would only be out the $450 I paid for the head unit which I can probably EBay. I'm anxiously awaiting the AVIN unit as long as they make a unit that uses the cubby hole and only requires a small hole. Those videos of guys cutting up their dashboards for the other AVIN units are painful to watch.
Appreciate 0
      12-06-2018, 10:10 AM   #4
berkantv
Registered
0
Rep
2
Posts

Drives: E89 2.3sdrive z4
Join Date: Dec 2018
Location: Turkey

iTrader: (0)

No way. only the original part.
Appreciate 0
      12-06-2018, 04:30 PM   #5
Dusty78
New Member
15
Rep
22
Posts

Drives: 2012 Z4 28i
Join Date: Sep 2018
Location: Charlotte NC

iTrader: (0)

Quote:
Originally Posted by berkantv View Post
No way. only the original part.
Huh? If you are referring to the original amp it's sounded like dog shit in a tin can. The JL Audio amp coupled with the Pioneer deck sounds 1000 times better
Appreciate 0
      12-06-2018, 08:08 PM   #6
dcg78
Enlisted Member
2
Rep
37
Posts

Drives: 11' Sdrive35i 6-speed
Join Date: Feb 2018
Location: Seattle

iTrader: (0)

Quote:
Originally Posted by Dusty78 View Post
Huh? If you are referring to the original amp it's sounded like dog shit in a tin can. The JL Audio amp coupled with the Pioneer deck sounds 1000 times better
Donít feed the troll lol.

Nice setup! I think I might do this myself! Did you change out the speakers as well? How many channel amp?
Appreciate 0
      12-07-2018, 08:32 AM   #7
Dusty78
New Member
15
Rep
22
Posts

Drives: 2012 Z4 28i
Join Date: Sep 2018
Location: Charlotte NC

iTrader: (0)

6 channel amp. I kept the factory speakers and they sound great with the new setup.
Appreciate 0
      12-07-2018, 05:26 PM   #8
tommylotto
Enlisted Member
United_States
0
Rep
35
Posts

Drives: 2015 BMW Z4 sDrive28i
Join Date: Jun 2018
Location: Laguna Hills, CA

iTrader: (0)

Here is another product that claims to convert regular audio signals to fiber optic and enable you to install an after market radio in the e89 without having to replace the amp.

I imagine it does the same thing that the harness I bought from Germany does.

I find the OEM BMW amp to be pretty darn good, but then my other car is a Fiat Chrysler Ghibli with stock audio, and it sounds like crap whenever I play anything but talk radio.
Appreciate 0
      06-06-2019, 02:34 AM   #9
fhmattsson
Registered
0
Rep
1
Posts

Drives: BMW Z4 89
Join Date: Jun 2019
Location: Sverige

iTrader: (0)

Hi, what componente did you use to get the steering wheel controls to work?

Di you get the PDC sount into the head unit as well?
Appreciate 0
      06-14-2019, 07:11 AM   #10
Z4ESS
Registered
0
Rep
1
Posts

Drives: BMW E89 30I
Join Date: Jun 2019
Location: Terrebonne Quebec

iTrader: (0)

I have a similar set-up Pioneer 3500nex with Audiotec Fischer MATCH amplifiers 8 channel PP86DSP and 2 channel M2FX for subwoofers.The only speakers changed were the 2 sub in the back for upw8bmw-s.
But I have SOS function error! Have you encounter the same problem? I’ve installed fiber optic loops to replace amp, head and satellite components. Did you install MOST fiber optic interface from avin usa
Harness that I used is from connects2 ctsbm013.2 and ctsmultilead.
Appreciate 0
      03-03-2020, 07:22 PM   #11
jog57
Registered
0
Rep
1
Posts

Drives: 2010 E89 3.5 Z4
Join Date: Mar 2020
Location: United States

iTrader: (0)

I have a similar set-up Pioneer 3500nex I went with BAVSOUND SPEAKERS
But I have SOS function error and the Phone button and Voice button dont work. Have you encountered a similar problem? Iíve installed Spiral Audio Most Interface with SWC and Chime
I guess that the Mic in the Steering Wheel column is connected to all of this but I don't no how.
Any ideas would be greatly appreciated
Appreciate 0
      03-05-2020, 11:38 PM   #12
cuddapah
Second Lieutenant
United_States
23
Rep
289
Posts

Drives: 2011 BMW Z4 sDrive 35i
Join Date: Feb 2012
Location: Jacksonville, FL

iTrader: (0)

Anybody tried this upgrade?
https://bimmersupplies.nl/product/bimmersupplies-mmi/
Appreciate 0
      03-06-2020, 02:30 AM   #13
DavesZed
Second Lieutenant
United Kingdom
47
Rep
236
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by cuddapah View Post
There is this option as well.... http://www.xcarlink.co.uk/product.ph...&cat=16&page=1
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      04-27-2020, 05:41 PM   #14
DutchBMWlover101
Registered
0
Rep
2
Posts

Drives: BMW 1 Series E81 118i
Join Date: Oct 2019
Location: Netherlands

iTrader: (0)

Quote:
Originally Posted by cuddapah View Post
Yes I did. I know the owner. His products are top notch, customer service is CRAZY good. Quick response on WhatsApp, knows his products.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:38 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST