New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      01-18-2015, 07:28 AM   #1
cuddapah
Second Lieutenant
United_States
23
Rep
289
Posts

Drives: 2011 BMW Z4 sDrive 35i
Join Date: Feb 2012
Location: Jacksonville, FL

iTrader: (0)

Center armrest compartment won't open

I have read about this issue before ... Z4's center armrest compartment won't open. Googled and tried everything. Scheduled an appointment with the dealer next week. Is there any way to open before the appointment ?
Appreciate 0
      01-18-2015, 02:29 PM   #2
chiu7526
Private
6
Rep
76
Posts

Drives: Z4
Join Date: Sep 2011
Location: United States

iTrader: (0)

I had this happened to me few weeks ago but I got it fixed. Remove the plastic cover behind the armrest. Once you get the cover open try to look for a metal part (ping) at the joint on the left side (passenger side) and push it back to the original position. Then you should be able to open the armrest compartment. Hope this helps
Appreciate 0
      01-18-2015, 05:33 PM   #3
cuddapah
Second Lieutenant
United_States
23
Rep
289
Posts

Drives: 2011 BMW Z4 sDrive 35i
Join Date: Feb 2012
Location: Jacksonville, FL

iTrader: (0)

Quote:
Originally Posted by chiu7526 View Post
I had this happened to me few weeks ago but I got it fixed. Remove the plastic cover behind the armrest. Once you get the cover open try to look for a metal part (ping) at the joint on the left side (passenger side) and push it back to the original position. Then you should be able to open the armrest compartment. Hope this helps
Thanks ! I was able to open the plastic cover behind the armrest. I couldn't locate the metal part (ping) ... I used flashlight also and couldn't locate it. Please see this picture towards the passenger side. Am I looking at right cover ? Appreciate your help.
Attached Images
 
Appreciate 0
      01-18-2015, 09:32 PM   #4
chiu7526
Private
6
Rep
76
Posts

Drives: Z4
Join Date: Sep 2011
Location: United States

iTrader: (0)

Quote:
Originally Posted by cuddapah View Post
Thanks ! I was able to open the plastic cover behind the armrest. I couldn't locate the metal part (ping) ... I used flashlight also and couldn't locate it. Please see this picture towards the passenger side. Am I looking at right cover ? Appreciate your help.

Yes you removed the right cover and the photo is taking at correct side where the metal part located. Look closely and you should be able to find it. It's pretty small but it's there.
Appreciate 0
      01-18-2015, 09:34 PM   #5
chiu7526
Private
6
Rep
76
Posts

Drives: Z4
Join Date: Sep 2011
Location: United States

iTrader: (0)

Try to open the compartment slightly then you should see what's causing the issue.
Appreciate 0
      04-08-2020, 01:32 PM   #6
fmorelli
Lieutenant
fmorelli's Avatar
United_States
142
Rep
551
Posts

Drives: Atacama Yellow 35i
Join Date: Mar 2016
Location: VA

iTrader: (0)

Here is more specific information to aide someone else with this issue. On the passenger side hinge, you'll see a metal piece that looks like it has indents. You'll notice driver side hinge does not have this. When you try to open the console, you'll see the passenger side hinge bind up. It's getting caught on that step metal piece.

Here's how to fix it: the metal part moves front to back. Take a small screwdriver and push the the metal piece backwards. You'll see it moves until there is a flat piece. Once pushed back the center console works. I've attached a photo of how the metal piece looks once it is pushed back.

Filippo
Attached Images
 
__________________
2011 35i MT Atacama ... lots of bits. Full Íhlins TTX custom suspension. Build thread.
Build sheet. Currently finishing suspension, fuel, ignition system with Barry Battle @ 3DMMotorsport.

Last edited by fmorelli; 04-08-2020 at 01:42 PM..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:22 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST