New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > Regional Forums > UK

Post Reply
 
Thread Tools Search this Thread
      05-10-2017, 04:08 AM   #1
BenGW91
Registered
0
Rep
3
Posts

Drives: BMW Z4 E89 Titanium Silver
Join Date: May 2017
Location: UK

iTrader: (0)

Help needed! Brake Reset

Hello all,

New to these forums.

Just had the rear brake pads replaced on by BMW Z4 E89 - I had them done at an indy mechanic. New pads and sensor.

But I cannot get the brake pad light to reset - it still says 1200 miles on the dash and the idrive in the navigation screen.

I have tried the usual - hold ODO until in service menu, navigate to rear brake pads, press BC to select reset, then hold BC to reset... this shows the little swirling clock, then continues to read 1200 miles.

The indy mechanic has tried with the diagnostic computer but still can't get to reset!!

am I missing something here, or do I need to take to a BMW workshop??

PLEASE HELP
Appreciate 0
      05-10-2017, 04:20 AM   #2
BenGW91
Registered
0
Rep
3
Posts

Drives: BMW Z4 E89 Titanium Silver
Join Date: May 2017
Location: UK

iTrader: (0)

Scratch that!

Just got them to reset..

had to release the parking brake, then release the foot brake, then do reset procedure

It works!!
Appreciate 0
Post Reply

Bookmarks

Tags
brake, e89, idrive, reset service brake pads warning, service

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:19 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST