New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications

Post Reply
 
Thread Tools Search this Thread
      05-07-2022, 11:40 AM   #1
asafZ435IS
Registered
0
Rep
1
Posts

Drives: Z4 E89 35IS
Join Date: May 2022
Location: Israel

iTrader: (0)

z4 35is transmission oil HOT warming alert

Hey
I own a bmw z4 35is 2010
I recently got a hot oil warming alert from the transmission (photos attached).
When the fault does not appear, the vehicle travels excellently and without any strange phenomenon, also true for a perfectly normal engine temperature (90-110).
The last time the vehicle reached a state that went into an emergency in the transmission and combined straight to N.
In the connection of a fault scanner it was found that one of the temperature sensors is fake and shows a heat of 170C degrees, while the rest of the temperature (engine, transmission oil) shows 70-80C degrees.
Even after the vehicle stood for 3 hours and cooled down the connection of the scanner showed exactly the same alert of the sensor. Even after 24 hours it was tested and the sensor gave a reading of 50C and suddenly jumped to 150C degrees.
I would love to know if anyone has encountered this phenomenon and what can be done, thanks
Attached Images
   
Appreciate 0
      05-27-2022, 07:27 PM   #2
Tangent
Lieutenant
United_States
229
Rep
506
Posts

Drives: 2016 M4, 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (2)

Quote:
Originally Posted by asafZ435IS View Post
... Even after 24 hours it was tested and the sensor gave a reading of 50C and suddenly jumped to 150C degrees.
...
That's a very strong indication of a faulty temperature sensor. Replace it and you should be good to go.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:21 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST