New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      02-25-2018, 03:58 AM   #1
cruisingdownthestreet
Second Lieutenant
No_Country
77
Rep
248
Posts

Drives: Z4
Join Date: Oct 2016
Location: LA county

iTrader: (0)

Does the technology tell me my car battery is weak or would I just know?

I've been experiencing a weak, laggy engine cold startup and iDrive screen is slow to open when pushing the "start" button since last Summer. Is the technology in the Z4 supposed to inform me of a weak battery or is this something I would know?

I drive the car once every 2-3 days and/or 40 miles a week.
__________________
Appreciate 0
      02-25-2018, 05:37 AM   #2
Asbjorn
Captain
Asbjorn's Avatar
China
40
Rep
752
Posts

Drives: ESS twin-turbo roadster (E89)
Join Date: Mar 2012
Location: European in China

iTrader: (0)

Your local stealership has a battery tester that can determine if your battery is getting weak. I have changed mine twice since 2009, and noticed the last one was an upgraded bigger battery than the previous. A fresh battery def helps with laggy cold starts as long as you do not park the car for too long. Remember programming is needed after changing battery.
Appreciate 0
      02-25-2018, 04:07 PM   #3
paris1
Lieutenant
31
Rep
522
Posts

Drives: 2013 35i Space Grey over Coral
Join Date: Oct 2014
Location: Northern Calif.

iTrader: (0)

Apparently certain electronic functions get a little wonky when the battery gets weak. see my post here:http://e89.zpost.com/forums/showthread.php?t=1464508
Appreciate 0
      02-27-2018, 12:20 PM   #4
Tangent
Second Lieutenant
United_States
47
Rep
206
Posts

Drives: 2001 330i , 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (1)

I started getting "Increased battery discharge" messages when my battery was dying if I didn't drive it for a while.
Appreciate 0
      02-28-2018, 05:47 PM   #5
NoQuarter
Captain
United_States
148
Rep
797
Posts

Drives: 2008 535xi / 2011 Z4 35Is
Join Date: Jan 2011
Location: Indiana

iTrader: (0)

Garage List
2012 BMW X5 35i  [0.00]
2007 335i  [0.00]
2007 530xi  [0.00]
2008 535xi  [0.00]
2011 Z4 35is  [0.00]
No real message. Just symptoms.

The increased discharge warning mentioned above is the biggest clue i think.
Appreciate 0
      03-01-2018, 06:36 AM   #6
Gaffa22
New Member
Gaffa22's Avatar
2
Rep
16
Posts

Drives: BMW E89 35i
Join Date: Oct 2017
Location: Norwich

iTrader: (0)

I get a warning on the dash if the battery voltages drops below 12.2V

Remember new batteries need to be registered to the car and coded if its a different spec
Appreciate 0
      04-26-2018, 06:24 PM   #7
cruisingdownthestreet
Second Lieutenant
No_Country
77
Rep
248
Posts

Drives: Z4
Join Date: Oct 2016
Location: LA county

iTrader: (0)

Does the CCA battery I choose matter if I don't live in cold climate but yet both are the same price and both fit the same make and model?

CCA 760A, Cranking amperage 950 A

vs

CCA 850 A, cranking amperage 1000 A
__________________
Appreciate 0
      04-27-2018, 11:43 AM   #8
Tangent
Second Lieutenant
United_States
47
Rep
206
Posts

Drives: 2001 330i , 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (1)

It matters in that you need to be sure to register the correct type and capacity but otherwise both are totally fine.
Appreciate 0
      04-27-2018, 07:21 PM   #9
cruisingdownthestreet
Second Lieutenant
No_Country
77
Rep
248
Posts

Drives: Z4
Join Date: Oct 2016
Location: LA county

iTrader: (0)

Quote:
Originally Posted by Tangent View Post
It matters in that you need to be sure to register the correct type and capacity but otherwise both are totally fine.
Man, I thought "registering" the battery went into some directory/file in some data bank but all it really is just resetting the stats.
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:37 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST