New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      02-08-2018, 08:11 AM   #1
tysonwills
Registered
0
Rep
2
Posts

Drives: 2004 z4 2.2
Join Date: Jul 2017
Location: belfast

iTrader: (0)

service light

I have the service light of the car on the stand on my e89.
I have reset it a number of times from the steering stalk but after a number of days it keeps coming back on.
Any ideas
Appreciate 0
      02-08-2018, 01:22 PM   #2
NoQuarter
Captain
United_States
148
Rep
797
Posts

Drives: 2008 535xi / 2011 Z4 35Is
Join Date: Jan 2011
Location: Indiana

iTrader: (0)

Garage List
2012 BMW X5 35i  [0.00]
2007 335i  [0.00]
2007 530xi  [0.00]
2008 535xi  [0.00]
2011 Z4 35is  [0.00]
Get yourself a BMW specific code scanner and see what service items are showing up.
Appreciate 0
      02-16-2018, 09:13 PM   #3
cdmulders
First Lieutenant
cdmulders's Avatar
Canada
42
Rep
358
Posts

Drives: 2013 535xi
Join Date: Dec 2009
Location: Montignies-Lez-Lens, Belgium

iTrader: (0)

Garage List
I would get the 'car on a lift' service light whenever the battery charge became low. I would drive the car for 60 minutes and the light would go away. I finally replaced the original battery just two weeks ago, after over 8 years of service from it. Our 2010 Z4 has only about 18k miles on it, as an aside.
__________________
2013 535xi, Carbon Black, beige interior, M Sport package, HUD, DDC & ARS
2010 Z4 35i, Crimson Red, beige interior, 6sp manual, Adapative Suspension
2000 528i, Cosmo Black, beige interior, Sport package (retired)
Appreciate 0
      02-16-2018, 09:26 PM   #4
paris1
Lieutenant
31
Rep
522
Posts

Drives: 2013 35i Space Grey over Coral
Join Date: Oct 2014
Location: Northern Calif.

iTrader: (0)

For me it was triggered by a bad brake wear sensor. So obviously, it can be a variety of things.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:36 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST