New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      08-12-2018, 01:17 PM   #1
Vetracr
Private First Class
23
Rep
152
Posts

Drives: 2010 BMW Z4 3.0
Join Date: Jun 2016
Location: Palm Beach, FL

iTrader: (0)

Oil & water temp gauges and oil pressure gauge instalation

I have been chasing a high oil temperature problem when I run track days my 2010 3.0si N52 6 speed. I have observed 165 degree C + oil temps on hot days at the track. First I added a Setrab 19 row oil cooler in the factory position in front of the passenger side wheel well. It was vented, baffled etc. so the design and installation was correct, still no difference in oil temp readings. Something was definitely amiss as this should not happen. I finally went all in to solve problem. I replaced Setrab cooler with a large Mishimoto oil cooler than runs from frame rail to frame rail located just behind the lower grill opening. Using the ports on the oil temperature thermostat housing I installed an oil temperature gauge on the line coming from the oil cooler. I also installed an oil pressure gauge on the port measuring the oil temp of the oil coming from the oil pump. I also installed a water temperature gauge on the water temp feed line to the water pump.

Gauge installation attached to cup holder for easy removal

Oil temp and oil pressure gauge sender installation

Water temperature gauge sender installation

Wider view of water temp, oil temp and oil pressure sender install

Back side view of gauge installation. Note disconnects so gauges can be removed when not at track.

Track results to follow
Attached Images
      

Last edited by Vetracr; 08-12-2018 at 01:23 PM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:39 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST