New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      08-07-2013, 12:23 PM   #1
jtran14
New Member
jtran14's Avatar
0
Rep
9
Posts

Drives: 2010 Z4 sDrive30i
Join Date: Dec 2012
Location: Austin, Texas

iTrader: (0)

Loss of all power mid-drive

Question folks,

I've got a '10 30i with about 30k miles on it, and its been at bmw for 5 days now due to loss of all electric power mid-drive, twice (pretty scary in mid traffic). I took it to them a few months back due to our recall, so I'm suprised its doing this post-recall fix. The service center is still trying to diagnose it, but I'm getting a little nervous since I only have about 6 months of warranty left and its already been serviced twice for brake squeal. My question is if anyone else has experienced this and what would you do in this situation? Its already paid off and I don't want to be stuck with a problem child after my warranty ends. Thanks in advance!
Appreciate 0
      08-07-2013, 12:34 PM   #2
BMWZ4RIDER
BMWZ4Rider
BMWZ4RIDER's Avatar
United_States
40
Rep
801
Posts

Drives: 2009 BMW Z4 35i
Join Date: Dec 2012
Location: Cape Cod, MA

iTrader: (0)

If you are going to keep it, the BMW Extended Protections Plans are worth checking out adding 3 more years or upto 70K or 100K mikes. Cheap coverage and cost insurance IF you have to use it.
__________________
2009 BMW Z4 35i/SMG/DCT/Premium,Cold, Sound PK/Com Acc/Ash/PDC/Wind Deflector/Smoked Reflectors/Red Calipers/Cl Mask/M Series Grill/6000K LED's/De-Badged/M Pedals/CF Mirrors-Engine Cover/Stubby/20% Tint/H8 LED's/LCI Side Markers/Sniper Sprint Spoiler/VMR V710/H&R Sport Springs/KN.
Appreciate 0
      08-07-2013, 01:09 PM   #3
nicknaz
Major General
nicknaz's Avatar
United_States
1963
Rep
8,964
Posts

Drives: E84 X135
Join Date: May 2008
Location: NorCal

iTrader: (0)

Total power loss could have resulted in a bad accident...

Call up BMWNA let them know of the situation and recall + repair attempts and see if they will help you out with an extended warranty or a really great trade in value to get into another car.

I personally wouldn't keep the car without warranty since electrical gremlins tend to consume a lot of time and money to find and fix
Appreciate 0
      08-07-2013, 02:29 PM   #4
jtran14
New Member
jtran14's Avatar
0
Rep
9
Posts

Drives: 2010 Z4 sDrive30i
Join Date: Dec 2012
Location: Austin, Texas

iTrader: (0)

Thanks for the suggestions, Im looking into it now now and I'm hoping to get my baby back soon! This 328i loaner just isn't doing it for me...
Appreciate 0
      08-07-2013, 03:22 PM   #5
vasmir
eh
vasmir's Avatar
56
Rep
286
Posts

Drives: 2011 E82 M, 2016 F25
Join Date: Jun 2012
Location: San Diego, CA

iTrader: (0)

Yeah could be lots of things... unfortunately electrical issues are sometimes the hardest to diagnose.
My last car had a faulty cam shaft sensor that died in exactly the same way; the car would just shut off randomly. It was a few years ago, but I remember it being a couple hundred $$ to fix.
Hopefully they can trace it down to one specific thing. Good luck, let us know.
Appreciate 0
      08-08-2013, 12:03 AM   #6
mikeinaustin
First Lieutenant
United_States
7
Rep
327
Posts

Drives: 2010 z4 3.0 crimson red
Join Date: Sep 2009
Location: austin, tx

iTrader: (0)

Did you lose electrical power or did the engine stall causing loss of power? If the engine stalled, there is a known issue with the engine management software. This was fixed by Bmw in 2010. There is a tsb about this. As you know, random engine stalls could cause loss of life. Bmw should have issued a safety recall but did not. Also the stall did not through any fault codes and that made diagnosing much harder. The hotter the weather, the more likely the chance. Also, sport mode made things much worse.
Appreciate 0
      08-08-2013, 10:12 AM   #7
jtran14
New Member
jtran14's Avatar
0
Rep
9
Posts

Drives: 2010 Z4 sDrive30i
Join Date: Dec 2012
Location: Austin, Texas

iTrader: (0)

I lost electrical power, coasted a short time (1-2 secs), power came back on, stopped the car in traffic, started up the engine again and turned home. I had a full tank on smooth straight road driving in normal mode. Still no new updates, but they did tell me that they saw the fault codes on when it happened, but can't reproduce it. It's been six day now...
Appreciate 0
      08-08-2013, 12:42 PM   #8
ManiacGT
Major
ManiacGT's Avatar
United Kingdom
49
Rep
1,465
Posts

Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

iTrader: (0)

Send a message via MSN to ManiacGT
So you've had the power cable recall done already?
Appreciate 0
      08-08-2013, 01:43 PM   #9
jtran14
New Member
jtran14's Avatar
0
Rep
9
Posts

Drives: 2010 Z4 sDrive30i
Join Date: Dec 2012
Location: Austin, Texas

iTrader: (0)

Yes, I took care of that a few months back
Appreciate 0
      08-08-2013, 02:23 PM   #10
CedarZ4
Captain
United_States
38
Rep
706
Posts

Drives: SO F83 M4, C7 Stingray Z51
Join Date: Jan 2013
Location: SoFL

iTrader: (2)

Quote:
Originally Posted by ManiacGT View Post
So you've had the power cable recall done already?
Kind of off-topic but no point in creating a new thread since it's not that big of a deal... What exactly did that recall change? Because when I brought in my car for the recall, when my car came back it was missing the red cover for the battery terminal... now it's just exposed. Did the recall have anything to do with that area?
Appreciate 0
      08-08-2013, 05:27 PM   #11
jtran14
New Member
jtran14's Avatar
0
Rep
9
Posts

Drives: 2010 Z4 sDrive30i
Join Date: Dec 2012
Location: Austin, Texas

iTrader: (0)

http://wheels.blogs.nytimes.com/2013...cable-problem/
Appreciate 0
      08-08-2013, 05:42 PM   #12
bmwmick
Second Lieutenant
bmwmick's Avatar
United_States
10
Rep
237
Posts

Drives: '97 Z3,'11 Z4 35i,'90 C4 Vette
Join Date: May 2011
Location: AZ/CA

iTrader: (1)

Quote:
Originally Posted by CedarZ4 View Post
Kind of off-topic but no point in creating a new thread since it's not that big of a deal... What exactly did that recall change? Because when I brought in my car for the recall, when my car came back it was missing the red cover for the battery terminal... now it's just exposed. Did the recall have anything to do with that area?
No,

The recall pertains to the large red insulated positive cable that feeds 12V to the fuse panel in the passenger footwell. From looking at ours, it appears that they simply cut that cable and add about an 8" section with a new connector on it to the fuse panel. They cover the splice with black heat shrink tubing that can be seen when you remove the trim panel hiding the fuse panel. It IS possible that they disconnected the battery during the recall work but it's not mandatory. They would most likely disconnect the negative cable and not the positive (much safer).

Mick
__________________
Mick
2011 35i 6-speed, ///M Sport, Deep Sea Blue, Black leather, Carbon trim, Cold Weather package, Premium package, 6CD changer. Delivered 7/15/11. Michelin Pilot SuperSport tires 10/24/12
Tucson,AZ/Santa Paula,CA
Appreciate 0
      08-10-2013, 12:33 PM   #13
jtran14
New Member
jtran14's Avatar
0
Rep
9
Posts

Drives: 2010 Z4 sDrive30i
Join Date: Dec 2012
Location: Austin, Texas

iTrader: (0)

So, I finally got my car back and they said it required a dme reprogramming. They didn't really give me details so I guess I'll just have to trust them and hope the gremlin's gone.

Side note, just replaced my rear rft's with Michelin pilot sport A/S 3 and the ride quality is already so much better!
Appreciate 0
      08-10-2013, 03:43 PM   #14
ManiacGT
Major
ManiacGT's Avatar
United Kingdom
49
Rep
1,465
Posts

Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

iTrader: (0)

Send a message via MSN to ManiacGT
Glad it's sorted. Are the michelins also RFTs or non RFTs?
Appreciate 0
      08-11-2013, 10:23 AM   #15
jtran14
New Member
jtran14's Avatar
0
Rep
9
Posts

Drives: 2010 Z4 sDrive30i
Join Date: Dec 2012
Location: Austin, Texas

iTrader: (0)

Non rft, I have a mobility kit now along with the michelin promise plan. Here's a little bit more info on the tires if you're interested:

http://www.topspeed.com/cars/car-new...-ar158814.html
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:10 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST