New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      04-18-2019, 05:16 PM   #89
bryanhoag
Private
United_States
24
Rep
98
Posts

Drives: 2013 Z4 sDrive 35i 6MT
Join Date: Jul 2018
Location: Charlotte, NC

iTrader: (0)

Interesting... I've never had the screen flicker on the iDrive screen or the reverse camera. Only when using CarPlay navigation.

The avin unit was not out when I was looking at options either. It definitely seems like a more polished product and is awesome for those who don't have iDrive. That said, if this UniChip system worked flawlessly, I think I'd choose it because it retains the stock set up with the folding screen.

I haven't studied the avin unit much yet since I haven't really considered switching at this point. But, CarPlay seems like a bit of an afterthought with that system... being Android-based. I suppose that doesn't matter that much though.

I wish more of us had access to shops that specialize in these aftermarket projects. I've done a lot more DIY with this car than any car I've had previously and it's been successful and a fun learning experience.... but there comes a point when I'd rather just pay someone else to do it.

Regarding top issues and overall reliability.... I've been lucky so far and haven't had any major issues. But, this forum can be scary. Sometimes I feel like I should avoid forums until I actually develop an issue rather than driving around wondering what's about to break.
Appreciate 0
      04-19-2019, 12:36 PM   #90
Zed4USA
New Member
United_States
0
Rep
23
Posts

Drives: 2014 BMW Z4 sDrive28i
Join Date: Apr 2019
Location: Earth

iTrader: (0)

Hi bryanhoag,

Which AVIN unit are you referring to? I checked their website and couldn't find an AVIN solution for the e89.

Quote:
Originally Posted by bryanhoag View Post
…The avin unit was not out when I was looking at options either. It definitely seems like a more polished product and is awesome for those who don't have iDrive.…

I haven't studied the avin unit much yet since I haven't really considered switching at this point. But, CarPlay seems like a bit of an afterthought with that system... being Android-based. I suppose that doesn't matter that much though.…
Appreciate 0
      04-19-2019, 12:39 PM   #91
bryanhoag
Private
United_States
24
Rep
98
Posts

Drives: 2013 Z4 sDrive 35i 6MT
Join Date: Jul 2018
Location: Charlotte, NC

iTrader: (0)

Zed4USA I don't know much about it. I don't think it's formally listed on their site yet for some reason. But people on this forum have managed to order and install it. The unit is discussed extensively on this thread:

https://e89.zpost.com/forums/showthread.php?t=1558926

I'd imagine all of your questions are answered there. Hope that helps!
Appreciate 0
      04-19-2019, 01:01 PM   #92
Zed4USA
New Member
United_States
0
Rep
23
Posts

Drives: 2014 BMW Z4 sDrive28i
Join Date: Apr 2019
Location: Earth

iTrader: (0)

Oh, I see. I guess that would make sense from the title of the thread. At this point, I think most of the discussion in that thread is revolving around a non AVIN item (an android screen compatible with iDrive - if you have it) which people are ordering from China. My understanding it that AVIN will not be bringing that item to the USA (unfortunately).

Quote:
Originally Posted by bryanhoag View Post
Zed4USA I don't know much about it. I don't think it's formally listed on their site yet for some reason. But people on this forum have managed to order and install it. The unit is discussed extensively on this thread:

https://e89.zpost.com/forums/showthread.php?t=1558926

I'd imagine all of your questions are answered there. Hope that helps!
Appreciate 0
      04-19-2019, 01:04 PM   #93
bryanhoag
Private
United_States
24
Rep
98
Posts

Drives: 2013 Z4 sDrive 35i 6MT
Join Date: Jul 2018
Location: Charlotte, NC

iTrader: (0)

@Zed4USA Sorry. Just realized you've already posted in that forum. That's the unit I was referring to.
Appreciate 0
      04-21-2019, 07:42 PM   #94
gghtpc
New Member
United_States
5
Rep
10
Posts

Drives: 2016 Z4 Sdrive35i
Join Date: Mar 2013
Location: Seattle, WA

iTrader: (0)

Installation complete on 2016 Z4

Thanks to all the videos and pictures in this group, I was able complete the installation

I decided to run the mic under the gear shift and place it in the ashtray.

Special thanks for the Video explaining how to open the CIC unit


Local CarToys wanted $300! I had to open the unit install twice but it worked.
Appreciate 0
      06-29-2019, 06:05 AM   #95
Go351
Private
4
Rep
65
Posts

Drives: 2016 M4 Coupe Sakhir Orange
Join Date: Feb 2016
Location: Australia

iTrader: (0)

support from unichip

Hi all anyone been able to get updated files from unichip support lately. I have not been able to reach them in the last 40 days.

I need the latest firmware files please. Particularly if the Android auto beta has been updated.

Thanks
Appreciate 0
      06-29-2019, 07:22 PM   #96
bryanhoag
Private
United_States
24
Rep
98
Posts

Drives: 2013 Z4 sDrive 35i 6MT
Join Date: Jul 2018
Location: Charlotte, NC

iTrader: (0)

Go351 I reached out to UniChip a while ago about one of their other products and never heard back, which is unusual. They always replied within 24 hours (usually less) back when I was getting my CarPlay system set up and troubleshooting thereafter. Maybe they've closed up shop? Or just sick of hearing from us e89 guys?
Appreciate 0
      06-30-2019, 09:11 PM   #97
Go351
Private
4
Rep
65
Posts

Drives: 2016 M4 Coupe Sakhir Orange
Join Date: Feb 2016
Location: Australia

iTrader: (0)

Quote:
Originally Posted by bryanhoag View Post
Go351 I reached out to UniChip a while ago about one of their other products and never heard back, which is unusual. They always replied within 24 hours (usually less) back when I was getting my CarPlay system set up and troubleshooting thereafter. Maybe they've closed up shop? Or just sick of hearing from us e89 guys?
Thanks Bryan
Hummm.... Not good.
Appreciate 0
      08-19-2019, 01:14 AM   #98
gghtpc
New Member
United_States
5
Rep
10
Posts

Drives: 2016 Z4 Sdrive35i
Join Date: Mar 2013
Location: Seattle, WA

iTrader: (0)

My CarPlay navigation is erratic at best. Position is almost always off leading to to reroutes. No answer to emails for support
Appreciate 0
      08-20-2019, 09:04 AM   #99
PaulVerkleij
the dutchman
Netherlands
0
Rep
8
Posts

Drives: BMW Z4 2010 2.3
Join Date: Jan 2019
Location: The Netherlands

iTrader: (0)

Quote:
Originally Posted by gghtpc View Post
My CarPlay navigation is erratic at best. Position is almost always off leading to to reroutes. No answer to emails for support
Please note, a CarPlay box does not navigate. It's your phone that is navigating. What I noticed is that in the car, in a flip cover with bank cards you may limit the GPS antenna from your phone.
My experience is to open the flip cover, exposing the GPS antenna and placing the phone in the armrest minimizes the GPS glitches. It is however no guarantee.
Appreciate 0
Post Reply

Bookmarks

Tags
apple car play

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:05 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST