New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications

Post Reply
 
Thread Tools Search this Thread
      10-10-2016, 09:34 PM   #23
Bleen
Private
Bleen's Avatar
United_States
5
Rep
98
Posts

Drives: 2012 BMW Z4 35i
Join Date: Jun 2013
Location: Glendale, CA

iTrader: (0)

Quote:
Originally Posted by 35i-Nut View Post
nice feedback , thanks for posting

Are you running DCT or manual ?
DCT...

I have noticed that the gas mileage has gone down from 20 to 16.5 mpg

Also wondering if it'll pass smog.

I did also see the temperature go up really really fast... to over 102f in a few minutes. I'm unsure if the car did this before the tune. I'm talking about the supposed outside temperature.

I ended up flashing it again (2 minute mode) to loud burble and it was too much, there were sharp bangs I did not like. So I rolled it back to medium.

I forgot to put it in airplane mode and realized mid-tune. I freaked out and put the airplane mode in the middle of the flash. The car did not like this and refused to take any more input until I restarted both the car and the app. For some reason bluetooth was on, it wasn't until I set it off that it worked again. Had a few moments of cold sweat there. While flashing, the car throws a lot of errors and will not start.

The risk of this is... something happens while flashing, and goodbye car.

On second thought, I think it's a bit too risky to do this for such small gains... maybe it'd make more sense on a modded car. Since I have already flashed, it I'll keep using it for a while and see if I flash back to stock or not.
__________________
Appreciate 0
      10-10-2016, 11:51 PM   #24
Tangent
Second Lieutenant
United_States
47
Rep
206
Posts

Drives: 2001 330i , 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (1)

Had some scary moments with my first MHD flashing attempts tonight. It connected just fine and all seemed to be going well, but then it got this error:

Failed to write ECU.

Failed to write section paket 6234

I got this with the Stage 1 and the Stage 0. After both of those I waited and tried to start the car and it would just crank without ever firing. I then tried to flash to stock software and it completed normally and the car runs again at least. In all attempts the phone was in airplane mode and from the fact that my charger dropped into float mode just a couple of minutes after flashing ended I know battery voltage never got low.

Is it possible that it needed to be updated to the latest software before I try to install the other tunes and that if I try again it'll work? This is a 2011 that presumably has the original factory installed software...
Appreciate 0
      10-11-2016, 12:22 AM   #25
talhagursoy
First Lieutenant
talhagursoy's Avatar
United_States
101
Rep
300
Posts

Drives: Bmw Z4 sDrive35i
Join Date: Feb 2014
Location: Fairfax, VA

iTrader: (1)

Quote:
Originally Posted by Tangent
Had some scary moments with my first MHD flashing attempts tonight. It connected just fine and all seemed to be going well, but then it got this error:

Failed to write ECU.

Failed to write section paket 6234

I got this with the Stage 1 and the Stage 0. After both of those I waited and tried to start the car and it would just crank without ever firing. I then tried to flash to stock software and it completed normally and the car runs again at least. In all attempts the phone was in airplane mode and from the fact that my charger dropped into float mode just a couple of minutes after flashing ended I know battery voltage never got low.

Is it possible that it needed to be updated to the latest software before I try to install the other tunes and that if I try again it'll work? This is a 2011 that presumably has the original factory installed software...
We had the same issue on my friends 335 and problem was solved with brand new tested kdcan cable with reliable OTG. If you got your cable from Amazon/Ebay, thats probably the case. I do not think it is because not updated, but you are better to update it since MHD fixed a lot of bugs and added new options like burbles etc.
__________________
Ar Catless DP, MHD Flash, BMS DCI, ER FMIC, ER CP, Forged DVs
Appreciate 1
Tangent47.00

      10-11-2016, 12:34 AM   #26
Tangent
Second Lieutenant
United_States
47
Rep
206
Posts

Drives: 2001 330i , 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (1)

My first kdcan didn't work to even connect to the app so I made sure to get a tested one from a recommended source after that. Are the otg cables that touchy as well?

Oh and I meant the car's software, not MHD's if it makes any difference.
Appreciate 0
      10-11-2016, 01:57 AM   #27
talhagursoy
First Lieutenant
talhagursoy's Avatar
United_States
101
Rep
300
Posts

Drives: Bmw Z4 sDrive35i
Join Date: Feb 2014
Location: Fairfax, VA

iTrader: (1)

Quote:
Originally Posted by Tangent View Post
My first kdcan didn't work to even connect to the app so I made sure to get a tested one from a recommended source after that. Are the otg cables that touchy as well?

Oh and I meant the car's software, not MHD's if it makes any difference.
This was from Martial,creator of MHD.

"what K/Dcan cable do you have?

Let the battery fully charge before your next attempt. Test your OTG connection stability by reading a file like a movie off a USB disk.
If you still fail randomly and the battery + OTG topics are covered then you have a bad K-Dcan cable which is unfortunately common if you have a "random" ebay/amazon cable.
The only reliable / affordable provider in the US is:http://b i m m e r software.com/Cables"
__________________
Ar Catless DP, MHD Flash, BMS DCI, ER FMIC, ER CP, Forged DVs
Appreciate 1
Tangent47.00

      10-11-2016, 12:27 PM   #28
Tangent
Second Lieutenant
United_States
47
Rep
206
Posts

Drives: 2001 330i , 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (1)

Quote:
Originally Posted by talhagursoy View Post
This was from Martial,creator of MHD.

"what K/Dcan cable do you have?

Let the battery fully charge before your next attempt. Test your OTG connection stability by reading a file like a movie off a USB disk.
If you still fail randomly and the battery + OTG topics are covered then you have a bad K-Dcan cable which is unfortunately common if you have a "random" ebay/amazon cable.
The only reliable / affordable provider in the US is:http://b i m m e r software.com/Cables"
I'll test the OTG connection but the other bases are definitely covered. I got the kdcan cable from that exact source actually (followed the link in the MHD user's guide) and the battery voltage stayed pretty close to 13 the whole time. I'll give it another shot tonight assuming the OTG cable checks out.
Appreciate 0
      10-11-2016, 03:46 PM   #29
BQTuning
Banned
United_States
321
Rep
4,443
Posts

Drives: 2012 Z4 sDrive35i M Sport 6MT
Join Date: Nov 2010
Location: bq@bqtuning.com

iTrader: (0)

Quote:
Originally Posted by ljkiter View Post
Wow. I'm barely handling the stock 35i power at the moment
Oh boy I can see it now after going for a ride in a zilla tuned 35i(s)

Appreciate 0
      10-11-2016, 05:15 PM   #30
Bleen
Private
Bleen's Avatar
United_States
5
Rep
98
Posts

Drives: 2012 BMW Z4 35i
Join Date: Jun 2013
Location: Glendale, CA

iTrader: (0)

Sorry to repeat myself, if anybody has answers to the following questions it'll be super helpful:

1 - Have you noticed your MPGs going down for a Stage 1 stock flash?
2 - Will the car pass smog test with Stage 1 stock flash?
3 - Have you noticed any increase in operating / thermometer temperature? (not oil)

Thanks
__________________
Appreciate 0
      10-11-2016, 07:32 PM   #31
mrkoven
Second Lieutenant
48
Rep
269
Posts

Drives: 2016 Z4 35i
Join Date: Jan 2016
Location: Silicon Valley

iTrader: (0)

^ my mpg def dropped a few mpg after flash, i think stage 1 would pass but you can always flash to stock before your smog, havent noticed any dramatic temp increases
__________________
Mineral White FBO MHD Stage 2+
Focal & ARC Audio
Appreciate 0
      10-12-2016, 12:32 AM   #32
Tangent
Second Lieutenant
United_States
47
Rep
206
Posts

Drives: 2001 330i , 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (1)

So I tried flashing again tonight and same result. Since I didn't have another OTG cable (which I found out is the same one others have recommended anyway) to try I figured I might try the one other variable and I tried flashing using my tablet instead of my phone. Success! So there's something about my Droid Turbo 2 that doesn't play nice with this process while my Galaxy Tab works great.

I can definitely answer Bleen's question about fuel economy short term anyway. I expect my mpg to make a definite drop because it's gonna be hard to keep my foot out of the throttle for a while. The power delivery is so much smoother and there's definitely much more of it. Hitting the gas in first gear (manual trans) at about 10-15 mph results in wheelspin which it absolutely would never have done before. And as a bonus my idle is even smoother. Even with the difficulties I had (no fault of the developers) it just took a single drive to make me a huge fan on MHD.
Appreciate 0
      10-12-2016, 06:34 PM   #33
Bleen
Private
Bleen's Avatar
United_States
5
Rep
98
Posts

Drives: 2012 BMW Z4 35i
Join Date: Jun 2013
Location: Glendale, CA

iTrader: (0)

Quote:
Originally Posted by Tangent View Post
So I tried flashing again tonight and same result. Since I didn't have another OTG cable (which I found out is the same one others have recommended anyway) to try I figured I might try the one other variable and I tried flashing using my tablet instead of my phone. Success! So there's something about my Droid Turbo 2 that doesn't play nice with this process while my Galaxy Tab works great.

I can definitely answer Bleen's question about fuel economy short term anyway. I expect my mpg to make a definite drop because it's gonna be hard to keep my foot out of the throttle for a while. The power delivery is so much smoother and there's definitely much more of it. Hitting the gas in first gear (manual trans) at about 10-15 mph results in wheelspin which it absolutely would never have done before. And as a bonus my idle is even smoother. Even with the difficulties I had (no fault of the developers) it just took a single drive to make me a huge fan on MHD.
Thanks! What options did you choose?
- Limit power on 1st and second gear?
- Burble? If so, which level?
- Linear throttle?
- etc...?
__________________
Appreciate 0
      10-12-2016, 10:10 PM   #34
fmorelli
Lieutenant
fmorelli's Avatar
United_States
130
Rep
505
Posts

Drives: Atacama Yellow 35i
Join Date: Mar 2016
Location: VA

iTrader: (0)

I can tell you this: no matter how many times you try, if you use the typical K+DCAN cable (up to 2008), it won't work on our cars. Ask me how I know ...

The one to use is from bimmersoft.

Filippo
__________________
2011 35i MT Atacama ... lots of bits. Build thread.
Build sheet. Currently finishing suspension, fuel, ignition system with Barry Battle @ 3DMMotorsport.
Appreciate 0
      10-12-2016, 11:11 PM   #35
Tangent
Second Lieutenant
United_States
47
Rep
206
Posts

Drives: 2001 330i , 2011 Z435i
Join Date: Jun 2015
Location: California

iTrader: (1)

Quote:
Originally Posted by Bleen View Post
Thanks! What options did you choose?
- Limit power on 1st and second gear?
- Burble? If so, which level?
- Linear throttle?
- etc...?
I started with all the defaults but tonight I added linear throttle. With the extra power that should make control a whole lot easier for autocross. While it'll spin the tires in first even from a roll now I don't think I want to limit power yet; I'll just be a bit easier on the pedal off the line. The burble is tempting and I might play with that but I've read a few comments about people having issues that could be related to the raw fuel going though the exhaust with that so I'd keep it short and mild anyway.
Appreciate 0
      10-14-2016, 12:09 AM   #36
Bleen
Private
Bleen's Avatar
United_States
5
Rep
98
Posts

Drives: 2012 BMW Z4 35i
Join Date: Jun 2013
Location: Glendale, CA

iTrader: (0)

Update... I drove 44 miles in deep LA traffic today, with pockets of opening up but not too much... car returned 22 mpg one way, 20 the other... similar than before. So no apparent issues with gas mileage.
__________________
Appreciate 0
      10-14-2016, 01:09 AM   #37
NoQuarter
Captain
United_States
148
Rep
798
Posts

Drives: 2008 535xi / 2011 Z4 35Is
Join Date: Jan 2011
Location: Indiana

iTrader: (0)

Garage List
2012 BMW X5 35i  [0.00]
2007 335i  [0.00]
2007 530xi  [0.00]
2008 535xi  [0.00]
2011 Z4 35is  [0.00]
Quote:
Originally Posted by fmorelli View Post
I can tell you this: no matter how many times you try, if you use the typical K+DCAN cable (up to 2008), it won't work on our cars. Ask me how I know ...

The one to use is from bimmersoft.

Filippo
I use the same cable on my 2007, 2008 E60 and my 2011
E89.

I did have to open it up and make an adapter for a couple of the pins inside the cable. Basically I short a couple of pins together or open them depending on if I am working on the E89 or not.
Appreciate 0
      10-14-2016, 08:03 AM   #38
fmorelli
Lieutenant
fmorelli's Avatar
United_States
130
Rep
505
Posts

Drives: Atacama Yellow 35i
Join Date: Mar 2016
Location: VA

iTrader: (0)

Quote:
Originally Posted by NoQuarter View Post
I use the same cable on my 2007, 2008 E60 and my 2011
E89.

I did have to open it up and make an adapter for a couple of the pins inside the cable. Basically I short a couple of pins together or open them depending on if I am working on the E89 or not.
I understand the newer cable is backward compatible. I should have been more clear - the "common" cable ... 90% of what is on the market sold everywhere ... is only good up to 2008.

Filippo
__________________
2011 35i MT Atacama ... lots of bits. Build thread.
Build sheet. Currently finishing suspension, fuel, ignition system with Barry Battle @ 3DMMotorsport.
Appreciate 0
      10-15-2016, 06:53 PM   #39
NoQuarter
Captain
United_States
148
Rep
798
Posts

Drives: 2008 535xi / 2011 Z4 35Is
Join Date: Jan 2011
Location: Indiana

iTrader: (0)

Garage List
2012 BMW X5 35i  [0.00]
2007 335i  [0.00]
2007 530xi  [0.00]
2008 535xi  [0.00]
2011 Z4 35is  [0.00]
Quote:
Originally Posted by fmorelli View Post
I understand the newer cable is backward compatible. I should have been more clear - the "common" cable ... 90% of what is on the market sold everywhere ... is only good up to 2008.

Filippo
Not sure if I have an older one or what you are calling a newer one. I have had this cable since 2011. It worked on my 2007 and 2008 at the time. When I got my 2011 Z4 I had to make my cable forward compatible.

Ugh... I have a pic but my mobile doest seem to want
Me to post a pic.
Appreciate 0
      11-03-2016, 02:25 PM   #40
NoQuarter
Captain
United_States
148
Rep
798
Posts

Drives: 2008 535xi / 2011 Z4 35Is
Join Date: Jan 2011
Location: Indiana

iTrader: (0)

Garage List
2012 BMW X5 35i  [0.00]
2007 335i  [0.00]
2007 530xi  [0.00]
2008 535xi  [0.00]
2011 Z4 35is  [0.00]
The cable I am using for my 2007 and 2008 E60 and my 2011 E89.

I purchased it back in 2011 probably.

I move the jumper depending on if I am working with the 2011 or the others.

The jumper is a hack I made myself, it did not come this way when I bought it.

Appreciate 0
      12-16-2016, 11:37 PM   #41
Johnnyblaze535i
Registered
2
Rep
4
Posts

Drives: 2008 535i
Join Date: Aug 2016
Location: Los Angeles

iTrader: (0)

MHD Flash Options

I saw another post about options. I seem to have have miss fires and cant even get this dam thing to get out of 3rd gear. I can feel the power just awaiting to unleash... What options did you install... I have 08 535i E60

I dont went the loud burble but want as much power as possible
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:36 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST