New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications

Post Reply
 
Thread Tools Search this Thread
      09-25-2023, 05:39 PM   #1
gg.feisbuk
Registered
gg.feisbuk's Avatar
Italy
0
Rep
4
Posts

Drives: Bmw Z4 35i N54
Join Date: Jul 2020
Location: Italy

iTrader: (0)

Garage List
29D2 and 2DED errors on N54 with AEM wat meth kit

I've installed the AEM wat meth system on my Z4 E89 3L twin turbo.
I've the ibrid turbos running at 18psi.

I've installed 3 nozzle, first 880cc before throttle valve, two after throttle in front of cyl 1 2 and cyl 5 6, this two nozzle are 125cc each.
I'm running only with water, because I want to push down the intake air temp and EGT, and because I've not tuned the engine with dedicated map to run with wat-meth.

The AEM ECU set up is: start 8psi, end 25psi, in this way at 18psi I've not the maximum water pressure, but around as half.

Yesterday my car in 3rd gear at 6000rpm has registered two error log, 29D2 misfires cyl6, 2DED closed-current circuit violation, engine led alarm was turned on and engine coughed.

I've turned off the engine 30sec, turned on again and engine light was off and the engine run well.

Question are: I'm injecting too much water? I need to move ending point to 35psi? I need to run with meth also W/O dedicated tuning map ?

Thanks to everyone can help me to understand meaning of two error logs and to solve.
Appreciate 0
      09-26-2023, 03:22 AM   #2
B21
Lieutenant
B21's Avatar
116
Rep
539
Posts

Drives: E89 Atacama Yellow 35is
Join Date: May 2022
Location: Scotland..God’s own country

iTrader: (0)

Quote:
Originally Posted by gg.feisbuk View Post
I've installed the AEM wat meth system on my Z4 E89 3L twin turbo.
I've the ibrid turbos running at 18psi.

I've installed 3 nozzle, first 880cc before throttle valve, two after throttle in front of cyl 1 2 and cyl 5 6, this two nozzle are 125cc each.
I'm running only with water, because I want to push down the intake air temp and EGT, and because I've not tuned the engine with dedicated map to run with wat-meth.

The AEM ECU set up is: start 8psi, end 25psi, in this way at 18psi I've not the maximum water pressure, but around as half.

Yesterday my car in 3rd gear at 6000rpm has registered two error log, 29D2 misfires cyl6, 2DED closed-current circuit violation, engine led alarm was turned on and engine coughed.

I've turned off the engine 30sec, turned on again and engine light was off and the engine run well.

Question are: I'm injecting too much water? I need to move ending point to 35psi? I need to run with meth also W/O dedicated tuning map ?

Thanks to everyone can help me to understand meaning of two error logs and to solve.
I think you need to go to one of the more specialist groups to get good feedback on that I suspect .. eg S P O O L S T R E E T
__________________
Much modified 2011 Atacama Yellow 35is…previously a much modified 2012 Atacama Yellow 20i MSport
Change history here… https://www.dropbox.com/s/8h1vabklgz...0List.pdf?dl=0
Build thread here… https://z4-forum.com/forum/viewtopic.php?t=131886
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:20 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST