New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications

Post Reply
 
Thread Tools Search this Thread
      09-12-2015, 07:33 PM   #1
talhagursoy
First Lieutenant
talhagursoy's Avatar
United_States
102
Rep
300
Posts

Drives: Bmw Z4 sDrive35i
Join Date: Feb 2014
Location: Fairfax, VA

iTrader: (1)

30FF Trouble Code

Hi guys,

I was on the highway and half CEL came on. Read codes and it shows 30FF Turbocharger, charge-air pressure too low. I checked the vacuum lines they LOOKS okay. What else I have to check? I am running jb4 map 5 with catless donwpipe, and I didn't FEEL any power lose. Anyone had this problem before ?
__________________
Ar Catless DP, MHD Flash, BMS DCI, ER FMIC, ER CP, Forged DVs
Appreciate 0
      11-02-2015, 08:14 PM   #2
jts1981
Captain
jts1981's Avatar
203
Rep
888
Posts

Drives: n54
Join Date: Dec 2012
Location: NYC

iTrader: (0)

Quote:
Originally Posted by talhagursoy View Post
Hi guys,

I was on the highway and half CEL came on. Read codes and it shows 30FF Turbocharger, charge-air pressure too low. I checked the vacuum lines they LOOKS okay. What else I have to check? I am running jb4 map 5 with catless donwpipe, and I didn't FEEL any power lose. Anyone had this problem before ?
Did you ever figure it out?
__________________
GC LITES / BQ TUNE / MHD / FUEL IT BT ECA / WALBRO 525 LPFP / KW V3 / E9X M3 CONTROL ARMS / TURNER REAR CAMBER ARMS / RE BUSHINGS / H&R SWAYS / LUXON STRUTBAR / VRSF 7.5" FMIC / ER CP / TIAL BOV / VTT IN/OUTLETS / AFE PRO5R INTAKE / AR C.L. DP / BMS OCC / RB PVC / CF LIP + SIDE + SPOILER + DIFFUSER / IND REFLECTORS / BLK GRILLS / STUBBY / PB BBK / Forgestar F14 F: 19x9 et35 R: 19x10 et38/ Michelin PSS F: 245/35/19 R: 275/30/19
Appreciate 0
      11-02-2015, 10:28 PM   #3
talhagursoy
First Lieutenant
talhagursoy's Avatar
United_States
102
Rep
300
Posts

Drives: Bmw Z4 sDrive35i
Join Date: Feb 2014
Location: Fairfax, VA

iTrader: (1)

Quote:
Originally Posted by jts1981 View Post
Did you ever figure it out?
I think I have found the problem out. I was running with BMS Dual Cone Intake. That was very first time I was stuck in traffic jam over 2 hours with my new DCI. I removed them and installed the stock intake box with K&N filter and tight all silicons from intercooler to intake box. Stayed in traffic jam over 2 hours again and there was no code.
If you are getting the same trouble code, check also your vacuum lines and charge pipe.
__________________
Ar Catless DP, MHD Flash, BMS DCI, ER FMIC, ER CP, Forged DVs
Appreciate 0
      11-03-2015, 06:29 PM   #4
jts1981
Captain
jts1981's Avatar
203
Rep
888
Posts

Drives: n54
Join Date: Dec 2012
Location: NYC

iTrader: (0)

I'm not throwing codes now. Just possibly a small boost leak up top and curious to see where others are having leaks.
__________________
GC LITES / BQ TUNE / MHD / FUEL IT BT ECA / WALBRO 525 LPFP / KW V3 / E9X M3 CONTROL ARMS / TURNER REAR CAMBER ARMS / RE BUSHINGS / H&R SWAYS / LUXON STRUTBAR / VRSF 7.5" FMIC / ER CP / TIAL BOV / VTT IN/OUTLETS / AFE PRO5R INTAKE / AR C.L. DP / BMS OCC / RB PVC / CF LIP + SIDE + SPOILER + DIFFUSER / IND REFLECTORS / BLK GRILLS / STUBBY / PB BBK / Forgestar F14 F: 19x9 et35 R: 19x10 et38/ Michelin PSS F: 245/35/19 R: 275/30/19
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:34 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST