New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      12-11-2012, 08:03 PM   #1
Mayhem
Private First Class
 
Drives: 2012 Z4 sDrive35is
Join Date: Jan 2012
Location: Hollywood

Posts: 172
iTrader: (0)

Finally had enough of the Hummmm......

That high pitched hummm that many of us have experienced. Mine came and went. Sometimes it's louder than other times. Seems to get louder as the weather gets cooler. I didn't really notice it during the summer at all, but lately, I can hear it all the time. It's a high pitch humming noise coming from the rear. Doesn't seem to be tied to acceleration. So yesterday, I finally took it into the dealer after suffering from it off and on since the car was new. They listened to it, and proclaimed it was a faulty fuel pump. Job should be done in the morning. Hope that cures it once and for all.
Mayhem is offline  
0
Reply With Quote
      12-11-2012, 08:51 PM   #2
rking117
Captain
 
Drives: Z4 3.0i & 330i
Join Date: Aug 2012
Location: Central Florida

Posts: 964
iTrader: (0)

please let us know if this fixes the problem.
rking117 is offline  
0
Reply With Quote
      12-11-2012, 08:57 PM   #3
Crazykoh
Private First Class
 
Drives: 2012 35i DSB Walnut
Join Date: Dec 2011
Location: NC

Posts: 150
iTrader: (0)

Quote:
Originally Posted by rking117
please let us know if this fixes the problem.
Worked for mine, though they had to try twice as the second pump did it too. At least they noticed and it was all in the same visit.
Crazykoh is offline  
0
Reply With Quote
      12-12-2012, 03:20 AM   #4
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,254
iTrader: (0)

Send a message via MSN to ManiacGT
Quite common in the uk. It's not faulty as such, just noisy. I get more of a whine from the engine which I think is the belts. Nothing from the back but a roar!
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      12-12-2012, 02:18 PM   #5
jpwolfe31
Private
 
Drives: 2009 Z4 35i
Join Date: Jun 2012
Location: San Francisco Bay Area

Posts: 51
iTrader: (0)

I assume this is the low pressure fuel pump.

Can you tell if the hum went away completely, or was it just reduced in volume.
jpwolfe31 is offline   United_States
0
Reply With Quote
      12-12-2012, 04:43 PM   #6
tranquility
sportscars only
 
tranquility's Avatar
 
Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Toronto

Posts: 1,433
iTrader: (0)

Pretty much should be the LPFP. I switched to a different brand of gas and it went away. Not the perfect solution but I didn't want to change my pump.
tranquility is offline   Canada
0
Reply With Quote
      12-13-2012, 01:42 AM   #7
Mayhem
Private First Class
 
Drives: 2012 Z4 sDrive35is
Join Date: Jan 2012
Location: Hollywood

Posts: 172
iTrader: (0)

Quote:
Originally Posted by tranquility View Post
Pretty much should be the LPFP. I switched to a different brand of gas and it went away. Not the perfect solution but I didn't want to change my pump.
The sound is now completely gone. Why wouldn't want it replaced under warranty? Better that than it fail out of warranty, or even worse, having to live with that annoying noise.
Mayhem is offline  
0
Reply With Quote
      12-13-2012, 06:50 AM   #8
tranquility
sportscars only
 
tranquility's Avatar
 
Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Toronto

Posts: 1,433
iTrader: (0)

Quote:
Originally Posted by Mayhem View Post
The sound is now completely gone. Why wouldn't want it replaced under warranty? Better that than it fail out of warranty, or even worse, having to live with that annoying noise.
I've read about many who replaced the LPFP, some even more than once, and they still have that sound reoccur sometime afterwards, so I couldn't be bothered; also don't like the dealership tinkering w/ the car and replacing such a major part, esp to no effect for some.

I have since lapsed out of warranty but don't have the noise because I avoid that certain brand of gas.
tranquility is offline   Canada
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:37 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST