New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      11-08-2012, 02:44 AM   #1
mybank2828
Private First Class
 
Drives: z4 35i
Join Date: Mar 2011
Location: alhambra, ca

Posts: 107
iTrader: (0)

climate control for air condition doesn't work after putting idrive into dvd mode

Hi All,

Does anyone has this problem in their idrive. If you were park with the engine off and turn on a dvd movie. Then without turning off the dvd, you turn on the engine. You will see a complain saying "safety concern of movie not working while engine is ON. But then, I can turn on the air condition from that point. None of the climate control button works. I had to stop the car, and rest for a few hour, then it works again.
mybank2828 is offline  
0
Reply With Quote
      11-08-2012, 11:41 PM   #2
Asbjorn
Lieutenant
 
Asbjorn's Avatar
 
Drives: ESS twin-turbo roadster (E89)
Join Date: Mar 2012
Location: European in China

Posts: 540
iTrader: (0)

So you are saying, to reproduce this, I would just have to get in my car, put the key in (or just put in a DVD?), turn on a DVD movie, then start the engine? And the climate controls wont work for a few hours? Did you have the key in when you started the movie?

BTW, if your engine is warm, you should be able to turn on the heater even if the engine is off. Just press the "increase fan speed" button. This is a useful feature if you like to use you car as a mobile cinema...
__________________
Little known facts about BMW: 1) The N54 is still in production and used in the current Z4 35i and 35is. 2) In a Z4 you can get sport+ steering combined with normal suspension etc by selecting DSC=off. (Update: DSC=off also offers sports steering in the M135i) 3) All Z4s with 19" wheels are still only offered with the worst performing OEM tires ever sold with a DCT equipped BMW (Potenza RE 050 RFT).
Asbjorn is offline   China
0
Reply With Quote
      11-13-2012, 04:56 AM   #3
mybank2828
Private First Class
 
Drives: z4 35i
Join Date: Mar 2011
Location: alhambra, ca

Posts: 107
iTrader: (0)

yes, get in your car, without turning on the engine, turn on a dvd movie, then without exiting the dvd mode, turn on the engine and drive, then you can't turn the air condition on.
mybank2828 is offline  
0
Reply With Quote
      11-13-2012, 11:43 AM   #4
redhot
Private First Class
 
Drives: 09 Z4 sDrive35i
Join Date: Feb 2012
Location: Chandler

Posts: 130
iTrader: (0)

Quote:
Originally Posted by mybank2828 View Post
yes, get in your car, without turning on the engine, turn on a dvd movie, then without exiting the dvd mode, turn on the engine and drive, then you can't turn the air condition on.
I have had similar, yet dissimilar issue with my HVAC as I did not have DVD in the slot but a CD. To me it seems like a communication error on the MOST bus. Should be interesting to hear what your dealer has to say about it.

I was not able to replicate the dead HVAC panel as you are able to so here's hoping that they can narrow down on the root cause.
__________________
09 Z4 35i
redhot is offline  
0
Reply With Quote
      11-14-2012, 02:46 AM   #5
mybank2828
Private First Class
 
Drives: z4 35i
Join Date: Mar 2011
Location: alhambra, ca

Posts: 107
iTrader: (0)

there is a workaround though. As long as I switch back out of the dvd mode into CD or other mode, then it's fine. I will ask them when I go in for oil change
mybank2828 is offline  
0
Reply With Quote
      11-14-2012, 04:08 AM   #6
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,237
iTrader: (0)

Send a message via MSN to ManiacGT
Bizarre! I'll have to try this on mine, before it goes in for its software update (to prevent the theft issue we're having here)..
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      11-14-2012, 05:06 AM   #7
mybank2828
Private First Class
 
Drives: z4 35i
Join Date: Mar 2011
Location: alhambra, ca

Posts: 107
iTrader: (0)

what theft issue are you having?
try on yours and see if you have the same problem!
mybank2828 is offline  
0
Reply With Quote
      11-14-2012, 06:37 AM   #8
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,237
iTrader: (0)

Send a message via MSN to ManiacGT
Theft: The key cloning issue where people have units that connect into the ODB port to recode blank keys in their possession. They just break into your car, code a key and drive away!

BMW are rolling out a software update to prevent it... hopefully prevent it anyhow!
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      12-03-2012, 11:42 PM   #9
heha
Private First Class
 
Drives: z4
Join Date: Sep 2010
Location: SO Cal

Posts: 115
iTrader: (0)

hi i have question regarding my climate control. when i start the car air comes out from the vent, but this time the whole panel does not work, no lights turn on, even the demister. any idea whats wrong?
heha is offline   United_States
0
Reply With Quote
      12-04-2012, 05:36 AM   #10
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,237
iTrader: (0)

Send a message via MSN to ManiacGT
There's no valid reason that the whole panel should shut off. If you turn the fan speed to 0 it does go off but should reactivate on the demister button etc. Try adjusting the fan speed or temps. AUTO will not work with fan at 0.

Failing that, its a fault.
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      12-04-2012, 05:38 AM   #11
mybank2828
Private First Class
 
Drives: z4 35i
Join Date: Mar 2011
Location: alhambra, ca

Posts: 107
iTrader: (0)

yeah, I think you might have left your DVD mode on when you turn off the engine, true?
mybank2828 is offline  
0
Reply With Quote
      02-01-2013, 09:43 PM   #12
heha
Private First Class
 
Drives: z4
Join Date: Sep 2010
Location: SO Cal

Posts: 115
iTrader: (0)

i have this problem again, start the car , all climate control button wont work.

off the car, press fan button hot air will blow.

how do i get my a/c back climate working

went to dealer he say might be battery and ask me to drive a while and see if it going to be ok.
heha is offline   United_States
0
Reply With Quote
      02-02-2013, 03:40 AM   #13
mybank2828
Private First Class
 
Drives: z4 35i
Join Date: Mar 2011
Location: alhambra, ca

Posts: 107
iTrader: (0)

I think the most important thing is that you switch out of the dvd movie mode before you turn off your engine. But if that mode is on when you turn on your engine and the climate control doesn't. Then you need to got to the music mode from your dvd mode, and turn off the engine. Then wait couple of hours and the computer to reset to normal and your climate control can be active again. Well, at least that's how mine works. I also notice this same problem derives when I plug my cellphone through the usb plug in the hand rest compartment
mybank2828 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:24 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST