New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      11-07-2012, 11:40 AM   #23
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by Land_Shark View Post
Thank you for sharing the above info. I can tell you have done an excessive research. I cannot agree more on your comment on BMWHK, unfortunately.
don't tell that to my divorce lawyer.

Quote:
I find the prices very encouraging, I do not favor buying from the e-bay like sites. When you spend that much on a car, the source of where I get the accessories is very critical for me.
Agreed. At the prices in the post above which are both from genuine OEM parts importers in HK, I'm inclined to buy the genuine parts directly rather than eBay around.

Quote:
I don't mind spending extra bucks to get all the latest setup, so I don't regret it few months later.
Agreed. Combox might be a little more difficult to code for me as it's not an option on the July 2010 Z4 I have (only MULF2) but others have it working on similar cars, so I'll go that way and get the latest features I think.

Quote:
I have emailed bummer tech to send me the specs of what they have and what coding is needed for my CiC.. Will let you know what they get back to me with...
Let me know what you get. I found the replies from BimmerTech & BimmerNav to be pretty short with not much detail :-( But BimmerTech have great reviews from folks on this site. I think I wasn't asking the right questions. As soon as the guys in Mong Kok get back to me about the ICOM head I should start moving on this.
night199uk is offline  
0
Reply With Quote
      11-07-2012, 07:42 PM   #24
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

BimmerTech replied to my email referring to BimmerNav. They advised that their are the technical partner of bimmernav. Now the next reply went to Bimmernav to advise if their quote was a ULF2 or a combox.... This is becoming interesting!!!
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-07-2012, 11:22 PM   #25
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

BimmerNav confirmed that they quoted me for the Combox, there is no ULF2 for my car.
So I am now I am waiting for them to confirm if it was the Combox Telematic or the Combox Media.
Between, why are you working on the Combox Media? you do not want the "In Office" function?
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-08-2012, 04:54 AM   #26
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by Land_Shark
BimmerNav confirmed that they quoted me for the Combox, there is no ULF2 for my car.
So I am now I am waiting for them to confirm if it was the Combox Telematic or the Combox Media.
Between, why are you working on the Combox Media? you do not want the "In Office" function?
What was the manufacture date of your car? After Sept 2010 I think the Z4 gets Combox by default so that makes sense. Mine is July 2010 so still MULF I believe. But Combox can be retrofitted, just requires more coding.

I've got a HK contact for an ICOM, haven't paid for it yet but they say it only takes two days to arrive. Vendor D confirmed 3-4 weeks for the parts and vendor V 8-10 weeks. So I'll probably get the ICOM hopefully early next week and then place the order for the parts from Vendor D. Will end up being a Christmas project by the time they arrive I guess :-)
night199uk is offline  
0
Reply With Quote
      11-08-2012, 05:04 AM   #27
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Car is MY: 1/2011
I am now down to Combox Telematic but there are 2 models one was discontinued on 3/2011 and the 2nd replaced the DC one.
The question I am left with is would part#:842010925207161work for me
You quoted Combox media and not telematic, any reason??
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-09-2012, 02:43 AM   #28
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by Land_Shark
Car is MY: 1/2011
I am now down to Combox Telematic but there are 2 models one was discontinued on 3/2011 and the 2nd replaced the DC one.
The question I am left with is would part#:842010925207161work for me
You quoted Combox media and not telematic, any reason??
I don't have iDrive or CIC so Telematiks isn't much use for me I think. I may still get Telematiks, as long term plan is to retrofit CIC. But right now I'm inclined to start small. I can always resell the Combox Media later if I want to upgrade - prices seem to hold and I know a few folks that want retrofits in HK, so I don't think I'll lose money. Haven't heard from my ICOM reseller today, just waiting for bank account details so I can order. Don't think I'll have it for the weekend now. Should just go to Shenzhen myself and get it, but my visa is expired :-(
night199uk is offline  
0
Reply With Quote
      11-11-2012, 09:19 AM   #29
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Can you pm me your vendor details. I would want to check with him the price of the Combox telematic and it's accessories...

I am now dealing with another nightmare... Lost all sound in the car; radio, gong, PDC, etc... Otherwise everything else seems to work fine... Checked the dsp, no fuse there. Fuse sat the box seem all fine... Grrrr...
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-11-2012, 10:13 AM   #30
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by Land_Shark View Post
Can you pm me your vendor details. I would want to check with him the price of the Combox telematic and it's accessories...
Will do...

Quote:
I am now dealing with another nightmare... Lost all sound in the car; radio, gong, PDC, etc... Otherwise everything else seems to work fine... Checked the dsp, no fuse there. Fuse sat the box seem all fine... Grrrr...
Were you doing anything? Retrofit or some other work? Sounds like a problem on the MOST bus from my limited knowledge and some threads I've read elsewhere, the audio is supposed to be carried around on MOST. Possibly a faulty module or connection?
night199uk is offline  
0
Reply With Quote
      11-12-2012, 07:39 PM   #31
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

I have put an order for the Combox and the needed accessories.
Let the fun begin...
My ICOM will arrive on Wed, I will back to HKG on Thursday, so I guess will use it this
Weekend to diagnose the car and see if I can find where is the failure and why no sound at all in the car.
So far my suspicion is on the DSP (fried) if so, than I guess I will need to invest in an aftermarket Amp and put this project on the back of the burner.
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-12-2012, 07:53 PM   #32
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by Land_Shark View Post
I have put an order for the Combox and the needed accessories.
Which parts did you get? The ones from my list? I haven't ordered parts yet but I ordered an ICOM yesterday, should arrive today :-)

Quote:
Let the fun begin...
So far my suspicion is on the DSP (fried) if so, than I guess I will need to invest in an aftermarket Amp and put this project on the back of the burner.
You'll do the amp first and put the Combox in later? I'm interested in the amp upgrade too. Keep me up-to-date :-) Once I've tested the ICOM and ensured I can program/code the car and the ICOM works I'll be ordering the Combox parts. Who did you order from in the end, V or D?
night199uk is offline  
0
Reply With Quote
      11-12-2012, 10:11 PM   #33
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Quote:
Originally Posted by night199uk View Post
Which parts did you get? The ones from my list? I haven't ordered parts yet but I ordered an ICOM yesterday, should arrive today :-)
I went finally with Bimmer-Tech/Nav; the last thing I want is to find out that I have missed a part while doing the installation, and that I will need to wait another 4 weeks for that. Though, I paid for the premium ;-) (Grrr...)


Quote:
Originally Posted by night199uk View Post
You'll do the amp first and put the Combox in later? I'm interested in the amp upgrade too. Keep me up-to-date :-) Once I've tested the ICOM and ensured I can program/code the car and the ICOM works I'll be ordering the Combox parts. Who did you order from in the end, V or D?
I will have to do the amp first, cause I need the sound. I won't do a full upgrade for the sound right now... Xmas is at the corner and my kids won't be too happy if I put all the $$ in the car.. lol
So I will just change the amp (if it is indeed the amp) and than do the Combo, and work on the sound upgrade emmm.. maybe on CNY...

Last edited by Land_Shark; 11-12-2012 at 10:18 PM.
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-14-2012, 11:31 PM   #34
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Received my ICOM A+B+C yesterday, I will running a Diagnose on the car to see if I can determine if my DSP is dead (which I am still hoping it is not, kind of don't want to believe it is)
Will fuss a little with the ICOM and try to re-program few things in the car, (Mirrors closing/Opening when pressing the Key FOB, Digital speed display, activate the iDrive DVD, etc...) until I receive my Combox retrofit...

Did you receive your ICOM? How is it going?
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-15-2012, 01:25 AM   #35
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by Land_Shark View Post
Received my ICOM A+B+C yesterday, I will running a Diagnose on the car to see if I can determine if my DSP is dead (which I am still hoping it is not, kind of don't want to believe it is)
Will fuss a little with the ICOM and try to re-program few things in the car, (Mirrors closing/Opening when pressing the Key FOB, Digital speed display, activate the iDrive DVD, etc...) until I receive my Combox retrofit...

Did you receive your ICOM? How is it going?
Yup, got the ICOM last night. Still building the programming VMs I need on the Mac. Have ISTA/P, ISTA/D, and another VM for BMW Standard Tools with WinKFP an NCS Expert etc. Plugged the ICOM into the car briefly an watched it boot, but not connected to the laptop yet.

Also I read we need a PSU to power the car for longer programming exercises. I built a list of the options and went to Mong Kok Hak Po Road last night, but no-one has anything close. They pointed me to Ap Liu Street in SSP, so I will go there and try and source the PSU (another 3000 - 4000 HKD :-(). There is a real danger of bricking your ECUs apparently if you don't use one and the battery runs out during coding/programming. :-( Hopefully I can find something, will let you know.

Did you find your MOST port yet? Fucked if I can find it. I have a bad description from the BMW docs and a bad image from another E89 document that says its on the driver side, behind some trim near the a-pillar. A better image or description would be helpful. I don't know how to remove the trim there safely.
night199uk is offline  
0
Reply With Quote
      11-15-2012, 01:46 AM   #36
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Quote:
Originally Posted by night199uk View Post
Yup, got the ICOM last night. Still building the programming VMs I need on the Mac. Have ISTA/P, ISTA/D, and another VM for BMW Standard Tools with WinKFP an NCS Expert etc. Plugged the ICOM into the car briefly an watched it boot, but not connected to the laptop yet.

Also I read we need a PSU to power the car for longer programming exercises. I built a list of the options and went to Mong Kok Hak Po Road last night, but no-one has anything close. They pointed me to Ap Liu Street in SSP, so I will go there and try and source the PSU (another 3000 - 4000 HKD :-(). There is a real danger of bricking your ECUs apparently if you don't use one and the battery runs out during coding/programming. :-( Hopefully I can find something, will let you know.
Keep me posted. We can buy this online from the US.
On the BT retrofit, I was advised that the coding won't take much time, unless we hit problems!!!


Quote:
Originally Posted by night199uk View Post
Did you find your MOST port yet? Fucked if I can find it. I have a bad description from the BMW docs and a bad image from another E89 document that says its on the driver side, behind some trim near the a-pillar. A better image or description would be helpful. I don't know how to remove the trim there safely.
Check this site, page 34
http://www.scribd.com/doc/92249489/S...mplete-Vehicle

It shows clearly where is the location of the MOST; I have not checked it out yet though.
Taking off the trims is not a difficult job, you will need a plastic head screwdriver (or a plastic flat rice spoon), you just need to know the position of the clips and exercise some caution...
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-15-2012, 01:57 AM   #37
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

That is the E89 document I referred to with the bad image. Can you orientate yourself from that diagram? I can't work out where that is at all. Maybe I need to print it and take it to the car. :-) If you can describe to me where that is or take a wider picture might help me. Will let you know on the PSU.

Btw I haven't even ordered the Combox parts yet. Will have to do that soon and they will take 3-4 weeks to come :-(
night199uk is offline  
0
Reply With Quote
      11-15-2012, 02:06 AM   #38
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Ok, the photo you have in this file is for a left hand drive car.
On the left of the photo (where the (C) is), this is rubber of the door. if you open your RHD door, you will find the rubber of the door on the right.
See photo and let me know if you are clear to where it is now...
Attached Images
 
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-15-2012, 02:32 AM   #39
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Quote:
Originally Posted by night199uk View Post
Also I read we need a PSU to power the car for longer programming exercises. I built a list of the options and went to Mong Kok Hak Po Road last night, but no-one has anything close. They pointed me to Ap Liu Street in SSP, so I will go there and try and source the PSU (another 3000 - 4000 HKD :-(). There is a real danger of bricking your ECUs apparently if you don't use one and the battery runs out during coding/programming. :-( Hopefully I can find something, will let you know.
Are you talking about that??
http://www.shopbmwusa.com/ProductDet...cessories.aspx
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-16-2012, 04:38 AM   #40
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

I took out the side panel this pm, but I couldn't fine any MOST port. I will take out all the foot panel tomorrow morning to see where the heck is that MOST port...

Did you try finding it? Ay success?
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-16-2012, 04:55 AM   #41
Land_Shark
In The Flesh
 
Drives: Z4 sDrive 35i
Join Date: Oct 2010
Location: Hong Kong

Posts: 600
iTrader: (0)

Quote:
Originally Posted by Land_Shark
I took out the side panel this pm, but I couldn't fine any MOST port. I will take out all the foot panel tomorrow morning to see where the heck is that MOST port...

Did you try finding it? Ay success?
Edit: I finally found it, it is on the left side (driver seat side) I guess BMW did not bother changing its location from the LHD cars..
Tomorrow will fuss with the ICOM and see how that goes.
Land_Shark is offline   Hong Kong
0
Reply With Quote
      11-18-2012, 08:03 AM   #42
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by Land_Shark View Post
Edit: I finally found it, it is on the left side (driver seat side) I guess BMW did not bother changing its location from the LHD cars..
Tomorrow will fuss with the ICOM and see how that goes.
Hey, sorry, been a few days. Okay so today I took my ICOM and newly built VM downstairs. Found the MOST port thanks to your description and managed to get everything almost working, but having a few problems with NCS Expert & WinKFP and getting EDIABAS to connect at the moment.

I think it's just a simple problem with EDIABAS but I need to reinstall a few things to check. Ran out of time today to troubleshoot, but it was looking pretty promising for a bit.

How did you get on?
night199uk is offline  
0
Reply With Quote
      11-18-2012, 08:06 AM   #43
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

Quote:
Originally Posted by night199uk View Post
Hey, sorry, been a few days. Okay so today I took my ICOM and newly built VM downstairs. Found the MOST port thanks to your description and managed to get everything almost working, but having a few problems with NCS Expert & WinKFP and getting EDIABAS to connect at the moment.

I think it's just a simple problem with EDIABAS but I need to reinstall a few things to check. Ran out of time today to troubleshoot, but it was looking pretty promising for a bit.

How did you get on?
Oh BTW, regarding that PSU the Battery Charger won't do it. You need a Power Supply which can adopt the full load of the devices in the car apparently. From what I read, you can get away with it for a little bit of coding, but for programming you will definitely need a PSU. Not sure if you need to program anything for the Combox upgrade, depend if your software needs updating to support the Combox and what you ordered in the end.

You might be able to get away with just coding.

This thread is a good resource:
http://forums.bimmerforums.com/forum....php?t=1608896
night199uk is offline  
0
Reply With Quote
      11-18-2012, 08:08 AM   #44
night199uk
Enlisted Member
 
Drives: BMW Z4 sDrive23i
Join Date: Oct 2012
Location: Hong Kong

Posts: 34
iTrader: (0)

ICOM

Hey,

Did you find a way to power your ICOM up without using the car? Its pretty cramped in the car and I've heard we can power it off a 12V PSU. But I can't find any details on the pinouts etc. Would be great to be able to power it up on the bench so I can troubleshoot the EDIABAS problem. Not much space in the car.
night199uk is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:14 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST