New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      05-11-2013, 09:04 AM   #1
Lambobimmer
Captain
 
Drives: 2009 Z4 sDrive35i DCT
Join Date: Jan 2010
Location: Harrisburg, NC

Posts: 784
iTrader: (10)

Cobb Stage 2 tune finally installed on 2009 Z4

BIMMERPOST
     Featured on BIMMERPOST.com
I had a Cobb Accessport from my 2008 135i and I kept it to install on my 2009 Z4. I installed, AR DP, KW V3's, HFP FMIC and Milltek exhaust first. Once I installed these mods, I went to install my Cobb and I unfortunately found out that Cobb was not compatible with the 2009 Z4. I called Cobb and they told me that they would add support for my car.

Cobb found out that the DME in the 2009 is completely different than the 2010 and up Z4's and it took them 6 weeks for reengineer the DME. I got the program back last night and got it loaded onto my car and it screams.

I can't think Cobb enough because any other company would have not done this. They stand behind their product and added support for my car for free. Unlike ESS and other tuning companies, Cobb gives you all of their tunes from mild to extreme for free. They are always updating their tunes to make them better as well and all of the Cobb owners get this benefit.

If you own a 2009 Z4 35i then you probably have access to Cobb now. You should give them a call and see if you 2009 DME version is the same as mine was.

I would never consider another tuning company for the N54.

FWIW I dyno'd on a Mustang dyno on my 135i at 387rwhp and 420 ft/lb on this map.

On their race map, you can expect over 400hp and 450 ft/lb on the conservative mustang dyno. Last summer I trapped at 117 in my 135i on their stage II map in the 1/4 mile.

With DCT an on the race map I would expect that the Z4 would trap 120.
Lambobimmer is offline   United_States
0
Reply With Quote
      05-11-2013, 10:27 AM   #2
mpbruin108
Mpbruin108
 
mpbruin108's Avatar
 
Drives: I'm a hypermiler
Join Date: Jul 2011
Location: los angeles

Posts: 550
iTrader: (6)

??? I have had cobb on my car for about 6 months before I sold the Cobb recently. Never had a problem. Just made sure you had the -01 version of the cobb. Not sure why you had these problems. I was talking to Cobb about my car and they never mentioned anything about it not working with our cars before.
__________________
2015 M4 Mineral Grey with SO

2013 Tesla Model S, 2010 RR Phantom, 2014 S550, 2014 BMW X5, 2015 Cayenne S platinum edition
mpbruin108 is offline  
0
Reply With Quote
      05-11-2013, 10:43 AM   #3
Lambobimmer
Captain
 
Drives: 2009 Z4 sDrive35i DCT
Join Date: Jan 2010
Location: Harrisburg, NC

Posts: 784
iTrader: (10)

Quote:
Originally Posted by mpbruin108 View Post
??? I have had cobb on my car for about 6 months before I sold the Cobb recently. Never had a problem. Just made sure you had the -01 version of the cobb. Not sure why you had these problems. I was talking to Cobb about my car and they never mentioned anything about it not working with our cars before.
Interesting. I just assumed that the problem was with 2009 Z4's. Their website says that they only support the 2010 and up and that is why I thought that I had the problem. Anyways, they said that I have a unique DME version and they have never seen another one like it.
Lambobimmer is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:19 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST