New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      06-18-2012, 09:58 PM   #1
timwhayden
Private
 
Drives: '11 Z4is AW/Walnut
Join Date: Jul 2011
Location: Jackson,TN

Posts: 64
iTrader: (0)

Garage List
Major SmarTop malfunction resulting in expensive trip to dealer:

I installed the SmarTop about 9 months ago and did fine until the roof got stuck in the trunk and would not come up. I had to take it to the dealer and pay $250 dollars to get the top back up so I could then uninstall the SmarTop. It still would not work and I then had to pay $1200 to get a shorted out trunk release latch replaced and now it works fine. This of course was not covered by warranty since it was POSSIBLY related to the SmarTop. I really loved all the advantages provided by it but am afraid to get another now. I had hoped this was an isolated event with this product but it looks like someone else just posted with possibly a related problem. Just be aware of the possible risks with this product. And I so liked it...
__________________
Garage:
'11 Z4is
'09 Audi Q5
'07 Lamborghini Gallardo
timwhayden is offline   United_States
0
Reply With Quote
      06-19-2012, 12:41 AM   #2
Otago
Second Lieutenant
 
Drives: 09 Z4 sDrive 30i manual
Join Date: May 2009
Location: Hong Kong

Posts: 220
iTrader: (0)

Did u call SmartTop for help? They should have answers for the problems.
Otago is offline  
0
Reply With Quote
      06-19-2012, 04:58 AM   #3
lrc454
Enlisted Member
 
Drives: 2009 Z4 30i Steptronic
Join Date: Jan 2010
Location: Virginia

Posts: 47
iTrader: (0)

Tim,

If I understand correctly, the shorted out trunk release latch was the root cause but the dealer wouldn't cover under warranty due to the SmartTop mod?

I can't blame you for not wanting to reinstall the module though.

It doesn't really sound like the module was the cause? Are you thinking the module had something to do with it?
lrc454 is offline  
0
Reply With Quote
      06-19-2012, 08:14 AM   #4
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,254
iTrader: (0)

Send a message via MSN to ManiacGT
Its enough to make me leave it alone now... they're nice features but not at the risk of expensive repairs, related or not...
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      06-19-2012, 10:43 AM   #5
E36ic4Me
Private First Class
 
E36ic4Me's Avatar
 
Drives: Z4 & M3 Convertible
Join Date: May 2012
Location: Bay Area

Posts: 100
iTrader: (0)

I'm was also on an EOS forum (sold my EOS a month ago) and there have been similar discussions. Three different people had their smarttops put the top down for no reason in the middle of the night. One fella had his car parked outside, smarttop lowered the top and it was in the middle of a huge rainstorm. His car was ruined. I've been thinking of getting one for my Z4 but am starting to get a bit gun-shy.
E36ic4Me is offline   United_States
0
Reply With Quote
      06-19-2012, 11:17 AM   #6
nickm9
Private First Class
 
Drives: E89 Z4 35i - Alpine White
Join Date: Oct 2010
Location: London

Posts: 185
iTrader: (0)

I was thinking about it but now will leave well alone.....good job we have these forums, sorry for the software company though.....but potentially saved us all money
nickm9 is offline  
0
Reply With Quote
      06-19-2012, 07:02 PM   #7
Nv Z
New Member
 
Drives: 2012 Z4 35is
Join Date: Jan 2012
Location: Reno, Nevada

Posts: 27
iTrader: (0)

Quote:
Originally Posted by nickm9 View Post
I was thinking about it but now will leave well alone.....good job we have these forums, sorry for the software company though.....but potentially saved us all money
Same here. I almost pulled the trigger but decided to wait. Now after seeing these posts I will suffer without the "Smart-top".
Nv Z is offline   United_States
0
Reply With Quote
      06-19-2012, 07:12 PM   #8
rfx45
Lieutenant
 
rfx45's Avatar
 
Drives: E89
Join Date: Dec 2007
Location: CA

Posts: 567
iTrader: (0)

Garage List
2012 BMW Z4  [5.00]
Just curious but how did it get stuck in the position? Were you closing or opening the roof and it stopped working?

Or is it like E36ic4Me where it would just open up the top on it's own and then got stuck?
__________________
2012 Z4
http://e89.zpost.com/forums/image.php?type=sigpic&userid=32142&dateline=132899  8397
rfx45 is offline   United_States
0
Reply With Quote
      06-19-2012, 07:46 PM   #9
timwhayden
Private
 
Drives: '11 Z4is AW/Walnut
Join Date: Jul 2011
Location: Jackson,TN

Posts: 64
iTrader: (0)

Garage List
Of course they said the SmarTop caused the shorted trunk release and I'm not sure they're wrong because when everything crashed I could not turn off the SmarTop with the blinker stalk which you are supposed to do when you take it to the dealer so his computer won't pick up you have installed it. In fact it would not respond at all leading me to believe that it had crashed possibly taking the trunk release with it. I was afraid it may have shorted out the top control module that it is plugged into but that fortunately was not the case.
__________________
Garage:
'11 Z4is
'09 Audi Q5
'07 Lamborghini Gallardo
timwhayden is offline   United_States
0
Reply With Quote
      06-20-2012, 02:12 AM   #10
persian54
Lieutenant General
 
persian54's Avatar
 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

Posts: 15,762
iTrader: (291)

wow very strange

I've had the ST on both my Z4s and E93s for the past couple of years and never experienced something like this

Scary....


So how did it get stuck? I mean, were you operating it and it just stopped working or...?
persian54 is offline   United_States
0
Reply With Quote
      06-20-2012, 04:55 AM   #11
lcheong
New Member
 
Drives: 2011 Black Sapphire 30i Z4, Bl
Join Date: May 2012
Location: Marin County, CA

Posts: 22
iTrader: (0)

I have had my smartTOP installed for a few months now and absolutely love it with no issues. I have taken it off and reinstalled it a few times before taking it in for service and it was clean each time. I also am curious if these issues people have seen are with the plug-n-play version or the one that you have to wire together. I have the newer plug-n-play type.
lcheong is offline  
0
Reply With Quote
      06-20-2012, 03:35 PM   #12
silverstone_ttlz4
Private First Class
 
Drives: 09 Z4 35i
Join Date: Feb 2012
Location: Boston

Posts: 107
iTrader: (0)

I'm hoping to read more about people having had these units installed in their Z4s and other cars for years without issues, because I really like the unit and don't want to uninstall it.
silverstone_ttlz4 is offline  
0
Reply With Quote
      06-20-2012, 03:53 PM   #13
Vintage
Colonel
 
Vintage's Avatar
 
Drives: 2010 Z4 35i and 2014 535d x
Join Date: Aug 2009
Location: Austin, Texas

Posts: 2,215
iTrader: (0)

I have had ZERO issues with Smart Top. I too feel the Smart Top probably had nothing to do with the problem, but the dealer/BMWNA saw it and used it as an excuse not to warrant the issue. BMW is famous for this crap and I do not want to get started as I have had two major issues with them on similar but more significant problems.

However, this is the bottom line, any time you modify your car from stock you run this risk.
Vintage is offline   United_States
0
Reply With Quote
      06-20-2012, 05:48 PM   #14
Nv Z
New Member
 
Drives: 2012 Z4 35is
Join Date: Jan 2012
Location: Reno, Nevada

Posts: 27
iTrader: (0)

However, this is the bottom line, any time you modify your car from stock you run this risk.[/quote]

Exactly. And you can't blame BMW for not covering an add on by the owner.
If I ever install something that could potentially cause a malfunction, I wouldn't even think for a second that BMW should repair it for free. That is the chance that we take.
Nv Z is offline   United_States
0
Reply With Quote
      06-20-2012, 08:27 PM   #15
timwhayden
Private
 
Drives: '11 Z4is AW/Walnut
Join Date: Jul 2011
Location: Jackson,TN

Posts: 64
iTrader: (0)

Garage List
I was lowering the top and it went all the way down but the trunk would not lock and the red "top malfunction" message came on and never went off. The red/green light on the top switch would not come on and the windows were all frozen. The trunk lid would bounce up and down but not latch. It was the older SmarTop version that had to be wired in instead of the newer plug and play.
__________________
Garage:
'11 Z4is
'09 Audi Q5
'07 Lamborghini Gallardo
timwhayden is offline   United_States
0
Reply With Quote
      06-21-2012, 01:16 AM   #16
Otago
Second Lieutenant
 
Drives: 09 Z4 sDrive 30i manual
Join Date: May 2009
Location: Hong Kong

Posts: 220
iTrader: (0)

Quote:
Originally Posted by Nv Z View Post
However, this is the bottom line, any time you modify your car from stock you run this risk.
Exactly. And you can't blame BMW for not covering an add on by the owner.
If I ever install something that could potentially cause a malfunction, I wouldn't even think for a second that BMW should repair it for free. That is the chance that we take.[/quote]

Otago is offline  
0
Reply With Quote
      06-28-2012, 02:19 PM   #17
persian54
Lieutenant General
 
persian54's Avatar
 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

Posts: 15,762
iTrader: (291)

unless you have an issue unrelated to the ST and they say they won't warranty because of the ST

like when you have a TPMS issue and they're blaming the ST... a TPMS issue that came up after THEY changed a tire... an issue that wasn't there before the tire change (with ST installed).

after this I never returned to said dealer which shall not be named
persian54 is offline   United_States
0
Reply With Quote
      06-29-2012, 02:25 AM   #18
Crazykoh
Private First Class
 
Drives: 2012 35i DSB Walnut
Join Date: Dec 2011
Location: NC

Posts: 149
iTrader: (0)

Quote:
Originally Posted by persian54
unless you have an issue unrelated to the ST and they say they won't warranty because of the ST

like when you have a TPMS issue and they're blaming the ST... a TPMS issue that came up after THEY changed a tire... an issue that wasn't there before the tire change (with ST installed).

after this I never returned to said dealer which shall not be named
Why not name the dealer? If they are behaving badly, call them out on it. Money talks.
Crazykoh is offline  
0
Reply With Quote
      06-29-2012, 01:12 PM   #19
bill123
Private First Class
 
Drives: Z4 35iS
Join Date: Nov 2009
Location: England

Posts: 131
iTrader: (0)

Sorry about your trouble OP
__________________
35iS, Deep Sea Blue, 19" 326 alloys, etc
bill123 is offline   United Kingdom
0
Reply With Quote
      07-13-2012, 05:32 PM   #20
jpwolfe31
Private
 
Drives: 2009 Z4 35i
Join Date: Jun 2012
Location: San Francisco Bay Area

Posts: 51
iTrader: (0)

We had major Smart Top issue too!

We just bought our 2009 Z4 35i about a month ago. As I was putting the top down. I stopped it about 1/2 way. When I tried to get it to go the rest of the way the top jammed really badly.

We had to call BMW Assist to get it driven (towed) to the dealership. BMW Concord found that a Smart Top was installed and told me that these devices can effect the timing of the various top opening and closing functions and this is why it jammed so badly. It was like the top went down without the trunk door opening all of the way.

They fixed the top at no charge and I decided to pay them $450 to remove the device. By the way, they say they have never seen a top jammed halfway up like ours before.

I am happy I do not need to worry about this anymore! The worst part was not having it for a week over the 4th. With its red interior, it is a natural for the 4th.
Attached Images
 
jpwolfe31 is offline   United_States
0
Reply With Quote
      07-13-2012, 06:11 PM   #21
fre2bpowerless
Private First Class
 
Drives: Yes. :D
Join Date: Dec 2011
Location: India

Posts: 126
iTrader: (0)

Did you guys face issues with the older module or the newer plug & play ones.

How annoying can BMW dealers get!! Anyway this makes me nervous and want to take the SmarTop off but the convenience... I actually ordered the module before I got the car



Figure if I ever have an issue, I'd blame it on the faulty fuel pumps. *wink wink nudge nudge*
fre2bpowerless is offline   India
0
Reply With Quote
      07-13-2012, 11:01 PM   #22
juhap
Lieutenant
 
juhap's Avatar
 
Drives: sDrive35i
Join Date: Jun 2009
Location: Finland

Posts: 530
iTrader: (0)

Quote:
Originally Posted by fre2bpowerless View Post
How annoying can BMW dealers get!!
They fixed the roof for free. I can think of a lot of things more annoying than that.
juhap is offline   Finland
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:59 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST