New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > Regional Forums > EUROPE - CONTINENTAL

Post Reply
 
Thread Tools Search this Thread
      04-29-2015, 11:05 AM   #1
Wheelerdealer61
New Member
0
Rep
10
Posts

Drives: BMW Z4 e89 SDrive23i 2011
Join Date: Apr 2015
Location: Malta

iTrader: (0)

Windscreen washer problem

Hi all

this is my first ever post so apologies if this subject might have already been brought up in the past (a quick search didn't bring up anything though).

I just got a used E89 SDrive 23i which is in fantastic shape and almost new. Really happy with it. Only glitch is that the windscreen washer only spurts out a few drops of water, even though the pump motor can be heard functioning. Headlight washers work ok.

Anyone else ever had this problem? Any solution suggested?

Tx and happy to join the community.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:12 PM.




zpost
zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST