New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      05-22-2010, 02:15 PM   #1
dwagner00
Private
2
Rep
71
Posts

 
Drives: Z4 35is
Join Date: Apr 2010
Location: Seattle

iTrader: (0)

2011 Z4 seat belt module?

I just got an email back from my dealer (my Z4 35is should have shown up today), saying that it was still at the port in LA, along with all the other 2011 Z4's waiting for a seat belt module, and won't be released for another 10 days.

More than a little irritated.
Appreciate 0
      05-22-2010, 04:12 PM   #2
teagueAMX
Colonel
teagueAMX's Avatar
United_States
32
Rep
2,086
Posts

 
Drives: Some are road worthy
Join Date: Apr 2009
Location: So Cal, USA

iTrader: (0)

I don't suppose BMW could have put the seat belt module on the same boat that they used to ship your car?

That's a bummer.

.
__________________
"Political correctness is a doctrine fostered by a delusional liberal minority and rabidly promoted by an unscrupulous mainstream media which holds forth the proposition that it is entirely possible to pick up a turd by the clean end".-- Unknown


Last edited by teagueAMX; 05-22-2010 at 07:28 PM.
Appreciate 0
      05-22-2010, 04:19 PM   #3
richard in NC
Major
United_States
23
Rep
1,369
Posts

 
Drives: 2009 Z4 35i
Join Date: Jul 2009
Location: Charlotte, NC

iTrader: (0)

I seriously doubt they forgot to install a seat belt module at the factory but maybe they had a code or error and needed to replace it before releasing the car from the VPC.
__________________
2015 M5, Alpine White/Full Black: Exec Pkg, Driver Asst, DCT, black 20s, More...
2013 X3 35i, Vermillion Red/Sand Beige: MSport, Premium, Technology, Premium Sound, Hud, More...
Gone '13 335is, '11 X5 50i, '09 Z4 35i, '08 550i, 06 X3, 06 650i, '02 M5, '99 540i
Appreciate 0
      05-22-2010, 04:45 PM   #4
dwagner00
Private
2
Rep
71
Posts

 
Drives: Z4 35is
Join Date: Apr 2010
Location: Seattle

iTrader: (0)

Quote:
Originally Posted by richard in NC View Post
I seriously doubt they forgot to install a seat belt module at the factory but maybe they had a code or error and needed to replace it before releasing the car from the VPC.
Yea, my guess is some kinda of "recall" type thing, but I haven't heard anything.
Appreciate 0
      05-22-2010, 07:09 PM   #5
ppanZ4
New Member
0
Rep
25
Posts

 
Drives: 2009 S35i Z4 Black-Coral Red
Join Date: Jul 2009
Location: Canada

iTrader: (0)

After 5000km...

Quote:
Originally Posted by dwagner00 View Post
Yea, my guess is some kinda of "recall" type thing, but I haven't heard anything.
I had to take my car back to replace the seat belt module as I had the seat belt light and air bag warning light come on while driving....seems there was a module problem.. so maybe they're replacing them now..
Appreciate 0
      05-22-2010, 11:31 PM   #6
TurboHank
Private
Taiwan
3
Rep
94
Posts

 
Drives: 2011MY Z4 35i M sports pkg
Join Date: Jan 2010
Location: San Francisco

iTrader: (0)

Quote:
Originally Posted by ppanZ4 View Post
I had to take my car back to replace the seat belt module as I had the seat belt light and air bag warning light come on while driving....seems there was a module problem.. so maybe they're replacing them now..
I just experienced that today! At first the seat belt light was on, then the airbag light came on too. Not cool!
Appreciate 0
      05-23-2010, 12:24 AM   #7
mikeinaustin
First Lieutenant
United_States
7
Rep
319
Posts

 
Drives: 2010 z4 3.0 crimson red
Join Date: Sep 2009
Location: austin, tx

iTrader: (0)

interesting. i recently bought a 1 day subscription to bmwtis. i took a look at all the info for e89's and did not see anything like this. however, i was not specifically looking for seat belt module issues.
Appreciate 0
      07-30-2010, 10:50 PM   #8
tranquility
sportscars only
tranquility's Avatar
Canada
35
Rep
1,502
Posts

 
Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by ppanZ4 View Post
I had to take my car back to replace the seat belt module as I had the seat belt light and air bag warning light come on while driving....seems there was a module problem.. so maybe they're replacing them now..
Quote:
Originally Posted by TurboHank View Post
I just experienced that today! At first the seat belt light was on, then the airbag light came on too. Not cool!
Hmm, I just got that recently. For me, it seems to be triggered when I use the heated seats function for the passenger side: the airbag light goes on along w/ the seatbelt light...then the airbag light goes off but the seatbelt light remains: does that mean the airbag would still deploy in an accident? I have to restart the car to get rid of the seatbelt light.

Did the fix work out? How long did it take?
Appreciate 0
      09-12-2010, 10:40 AM   #9
tranquility
sportscars only
tranquility's Avatar
Canada
35
Rep
1,502
Posts

 
Drives: 2011 Z4 sDrive 35i
Join Date: Aug 2007
Location: Toronto

iTrader: (0)

^update:
Dealer finally figured out that it was a faulty seat sensor which somehow is related to the heated seats ftn. Getting a replacement sensor soon.
Appreciate 0
      09-12-2010, 03:38 PM   #10
Mr. ///M3 RD
Major General
Mr. ///M3 RD's Avatar
Canada
149
Rep
7,863
Posts

 
Drives: E350 & 280 SL on Weekends :)
Join Date: May 2010
Location: GTA, Ontario - Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by dwagner00 View Post
I just got an email back from my dealer (my Z4 35is should have shown up today), saying that it was still at the port in LA, along with all the other 2011 Z4's waiting for a seat belt module, and won't be released for another 10 days.

More than a little irritated.
Sorry to hear that, it's a bummer with such nice top down weather and all. There is a seat belt mod mine was done last week.
__________________
Cheers, Rolf-Dieter

Life will take us to some interesting places, fortunately The ///M3 will too with a many of us know this very well
---> Click here for some good stuff I found
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:03 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST