New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      01-01-2018, 08:01 PM   #1
cbadz4
Registered
0
Rep
3
Posts

Drives: 2010 Z4 3.0
Join Date: Dec 2017
Location: California

iTrader: (0)

Windows, lights, turn signalas, roof inop...

I went to lower the roof on my 2010 Z4 3.0 and things went badly. The rear windows lowered, but the front ones did not. Now the windows (front/rear) windows will not work at all. The windows won't drop when the door is opened (making closing the doors a problem). Additional indications: headlights won't come on, high beams don't work, turn signals and hazards don't work and the brake lights will not work. There is a RED car on a lift displayed on the dash. I searched the forum, but mostly I found out how to reset the windows, that fix doesn't help this problem. ALL fuses have been removed and verified good (with a multimeter). Any thoughts? Thank you, in advance, for any assistance.
Appreciate 0
      01-02-2018, 12:34 AM   #2
paris1
Lieutenant
30
Rep
498
Posts

Drives: 2013 35i Space Grey over Coral
Join Date: Oct 2014
Location: Northern Calif.

iTrader: (0)

Body control module (located behind glove box) controls many electrical functions and is prone to failure. https://www.ebay.com/i/122794448689?chn=ps
Appreciate 0
      01-06-2018, 09:52 PM   #3
cbadz4
Registered
0
Rep
3
Posts

Drives: 2010 Z4 3.0
Join Date: Dec 2017
Location: California

iTrader: (0)

Thank you, any other ideas?

Thank you for the previous post. I bought the module and installed it. No change in status, the previously non-working items are still non-working. Any other suggestions about what is possibly wrong with the car?
Appreciate 0
      01-07-2018, 12:25 AM   #4
paris1
Lieutenant
30
Rep
498
Posts

Drives: 2013 35i Space Grey over Coral
Join Date: Oct 2014
Location: Northern Calif.

iTrader: (0)

Quote:
Originally Posted by cbadz4 View Post
Thank you for the previous post. I bought the module and installed it. No change in status, the previously non-working items are still non-working. Any other suggestions about what is possibly wrong with the car?
See below
Appreciate 0
      01-07-2018, 12:26 AM   #5
paris1
Lieutenant
30
Rep
498
Posts

Drives: 2013 35i Space Grey over Coral
Join Date: Oct 2014
Location: Northern Calif.

iTrader: (0)

Quote:
Originally Posted by cbadz4 View Post
Thank you for the previous post. I bought the module and installed it. No change in status, the previously non-working items are still non-working. Any other suggestions about what is possibly wrong with the car?
I don't think it's a "plug-n-play" module. When it was replaced on my car by the dealer, it had to be reprogrammed and I got the impression there was quite a bit of labor time involved. Nothing is easy on a BMW!
Appreciate 0
      01-08-2018, 10:00 PM   #6
cbadz4
Registered
0
Rep
3
Posts

Drives: 2010 Z4 3.0
Join Date: Dec 2017
Location: California

iTrader: (0)

Different Module, same symptoms

Installing the recently acquired BCM did not change any of the symptoms. The odds of a programming fix seem remote (different modules, identical malfunctions). Reading around the internet, people have experienced similar issues when the FRM failed. Anyone with experience with a failed FRM?
Appreciate 0
      01-10-2018, 08:39 PM   #7
Kessler35is
Second Lieutenant
United_States
29
Rep
208
Posts

Drives: 2015 F15 50i, 2016 E89 35is
Join Date: Jun 2013
Location: Tupelo, MS.

iTrader: (0)

Garage List
2016 Z4 35is  [0.00]
2015 X5 50i  [0.00]
That all depends on if the new BCM needs to be registered/paired with the car and code version matched to what is already in your car.


If your other modules are on code version 1 and this new BCM is on version 2 they will not match and may not be able to work together.

Having all of the modules flashed or reflashed to the same code could make that BCM come alive.

This is why when a new module is installed at the dealer they have to put it on the computer for hours. It goes through every firmware on every device to make sure they are all on the supported code matrix.


I say version 1 and 2 just as an example
Appreciate 0
      01-10-2018, 10:21 PM   #8
paris1
Lieutenant
30
Rep
498
Posts

Drives: 2013 35i Space Grey over Coral
Join Date: Oct 2014
Location: Northern Calif.

iTrader: (0)

Quote:
Originally Posted by Kessler35is View Post
That all depends on if the new BCM needs to be registered/paired with the car and code version matched to what is already in your car.


If your other modules are on code version 1 and this new BCM is on version 2 they will not match and may not be able to work together.

Having all of the modules flashed or reflashed to the same code could make that BCM come alive.

This is why when a new module is installed at the dealer they have to put it on the computer for hours. It goes through every firmware on every device to make sure they are all on the supported code matrix.


I say version 1 and 2 just as an example
That's exactly what my dealer told me when they replaced mine. It was an all day job with the actual box replacement only taking an hour or so!
Appreciate 0
      02-06-2018, 04:26 AM   #9
Dapix
Registered
0
Rep
2
Posts

Drives: Z4 E89 3.5i
Join Date: Aug 2017
Location: Vancouver

iTrader: (0)

Hi, somehow I manage to break one of my SIDE MARKER.
Anyone can advice where I ca buy a replacement. Thx
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:54 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST