New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      04-18-2013, 06:12 PM   #1
Moo
Gold Member
 
Moo's Avatar
 
Drives: PSYWGN
Join Date: Apr 2010
Location: Studio 69

Posts: 466
iTrader: (0)

My solution to the roof noise

After no less than 5 trips to the dealer, where they put felt tape on almost all contacts edges, the top still creaks and rattles

Obviously feeling rather discouraged, I took another look at the roof assembly and decided to try a simple experiment:

This is the "hole" that the roof tab sits into when the top is closed.


This is the metallic tab that goes into the hole.


This is me putting a layer of duct tape around the metallic tab.


Voila, no more noise!

Hope this helps some of you, cheers.
Moo is offline   No_Country
0
Reply With Quote
      04-18-2013, 07:08 PM   #2
jparnes1
Lieutenant Colonel
 
jparnes1's Avatar
 
Drives: 2006 525xi, 2012 Z4 35i
Join Date: Jan 2010
Location: Rochester, NY

Posts: 1,550
iTrader: (0)

Maniac, do you see this?
__________________
2006 525xi, Orient Blue Metallic, Beige leather, Dark Poplar trim, Premium Package, Cold Weather Package

2012 Z4 35i, ED 2/24/2012, Melbourne Red Metallic, Black Leather, Carbon Trim, 6MT, ///M Sport, CW, PP, PS, NAV, CA, LED Angel Eyes, red calipers, pedal covers, stubby antenna.
jparnes1 is offline   No_Country
0
Reply With Quote
      04-18-2013, 08:51 PM   #3
cdeslandes
Captain
 
cdeslandes's Avatar
 
Drives: 2010 Z4 s35i
Join Date: Apr 2010
Location: Connecticut

Posts: 660
iTrader: (0)

Garage List
LOL. That tape even looks like CF!
__________________
2010 BMW Z4 s35i
2013 Volvo XC90
cdeslandes is offline   United_States
0
Reply With Quote
      04-19-2013, 12:37 AM   #4
Asbjorn
Lieutenant
 
Asbjorn's Avatar
 
Drives: ESS twin-turbo roadster (E89)
Join Date: Mar 2012
Location: European in China

Posts: 497
iTrader: (0)

Quote:
Originally Posted by jparnes1 View Post
Maniac, do you see this?
Asbjorn is offline   China
0
Reply With Quote
      04-19-2013, 01:25 AM   #5
SchweiZ4
Private First Class
 
SchweiZ4's Avatar
 
Drives: 2010 Z4 23i
Join Date: Dec 2012
Location: Switzerland

Posts: 121
iTrader: (0)

Nice catch! Glad that it worked for you.
I like the, you can test this fix quickly and if it doesn't work, revert it quickly.

I am waiting for our Roof/Deck expert to comment on this one
SchweiZ4 is offline  
0
Reply With Quote
      04-19-2013, 01:26 AM   #6
ManiacGT
Major
 
ManiacGT's Avatar
 
Drives: Z4 sDrive 35i
Join Date: Jan 2011
Location: Manchester, UK

Posts: 1,199
iTrader: (0)

Send a message via MSN to ManiacGT
Lol yes I've already tried that. It didn't solve the clicking I get but introduced a slight jamming when the roof tried to unplug that locator so I removed the tape.
__________________
Black Sapphire BMW Z4 sDrive35i Mods: HiFi Tweeters Stubby LED Halos & Front Indicators DVDInMotion SmartTop 313 BMW Performance Alloys LCI Repeaters http://goo.gl/PF4nSz
ManiacGT is offline   United Kingdom
0
Reply With Quote
      04-19-2013, 04:21 PM   #7
morfinx
Shenanigans
 
morfinx's Avatar
 
Drives: E89 Z4 sDrive35i
Join Date: Jul 2010
Location: Austin, TX

Posts: 1,214
iTrader: (0)

Nice! I might have to try this!
__________________
E89 Z4 sDrive35i 7DCT "Zayna", Alpine White/Coral Red
E92 335i 6MT "Calixta", Space Grey/Coral Red [Retired]

morfinx is offline   United_States
0
Reply With Quote
      04-19-2013, 06:14 PM   #8
R1robot
Private First Class
 
R1robot's Avatar
 
Drives: 2003 Z4 2.5i
Join Date: Jan 2013
Location: Texas

Posts: 111
iTrader: (0)

Quote:
Originally Posted by ManiacGT View Post
Lol yes I've already tried that. It didn't solve the clicking I get but introduced a slight jamming when the roof tried to unplug that locator so I removed the tape.
use a thick condom on the tab
R1robot is offline   United_States
0
Reply With Quote
      04-21-2013, 06:26 PM   #9
bigendbob
Private
 
Drives: z4 23i Orion Silver
Join Date: Jun 2012
Location: west midlands

Posts: 61
iTrader: (0)

Try this;
http://www.z4-forum.com/forum/viewto...47943&start=15
bigendbob is offline  
0
Reply With Quote
      04-22-2013, 06:47 AM   #10
Gunzaro
Second Lieutenant
 
Drives: Speed Racer
Join Date: Jan 2011
Location: In transit

Posts: 252
iTrader: (0)

I put grease on mine. Thanks for the link Bigendbob. I have not tried these pads yet.

Last edited by Gunzaro; 04-22-2013 at 06:54 AM.
Gunzaro is offline   Cyprus
0
Reply With Quote
      04-22-2013, 08:49 PM   #11
HerrK
Lieutenant
 
HerrK's Avatar
 
Drives: 011 Z4 35i, 04 R1150RT
Join Date: Dec 2009
Location: CA

Posts: 587
iTrader: (0)

Quote:
Originally Posted by Moo View Post
This is the "hole" that the roof tab sits into when the top is closed.
If your hole or maybe a better term would be slot is old and no longer providing your "tab" with adequate lubrication to prevent squeaking. Do what males have been doing for centuries and replace the annoying dry slot.

1 pc 54377247854 - approx $15 depending on where you buy it.

OK, OK, so it's no worse than the condom comments.
__________________

HerrK - "It doesn't feel like a pair of turbo chargers. It feels like a pair of TESTIES!! BIG MEATY ONES!" - Jeremy Clarkson on the N54 powered Z4
May 2010 ED l 2011 35i l Crimson over Ext'd Coral Red w/brushed Alum l 6sp MT l Prem Sound l Sport Pack l 296's l Comfort Access l Alarm l Power Heated Seats l Nav

Last edited by HerrK; 04-22-2013 at 09:00 PM.
HerrK is offline  
0
Reply With Quote
      04-22-2013, 11:18 PM   #12
R1robot
Private First Class
 
R1robot's Avatar
 
Drives: 2003 Z4 2.5i
Join Date: Jan 2013
Location: Texas

Posts: 111
iTrader: (0)

Quote:
Originally Posted by HerrK View Post
If your hole or maybe a better term would be slot is old and no longer providing your "tab" with adequate lubrication to prevent squeaking. Do what males have been doing for centuries and replace the annoying dry slot.

1 pc 54377247854 - approx $15 depending on where you buy it.

OK, OK, so it's no worse than the condom comments.
Now that i think on it, a ribbed condom would probably work better.
R1robot is offline   United_States
0
Reply With Quote
      04-24-2013, 02:40 PM   #13
doomito
Registered
 
Drives: 2012 Z4 2.8i
Join Date: Feb 2013
Location: Buenos Aires

Posts: 2
iTrader: (0)

In ALL the forums I follow, there are endless threads regarding roof rattle, clicking, vibration or something like that. On the other hand, BMW position on this is "there are not reported problem" and this are isolated cases.

Being the fifth time I have to take my care to the dealer, and since according to them, there is NOTHING on the BMW worldwide database regarding this issues, I decide to just ask: HOW MANY OF Z4 OWNER HAVE OR DID HAVE PROBLEMS with their roof?

If there are a relative important Z4 owners with the same problem, I think we should present a form claim and have a solution. Please, comment if you are own of us
doomito is offline  
0
Reply With Quote
      04-26-2013, 05:40 AM   #14
c-dude
New Member
 
Drives: Mineral white 2012 e89 20i
Join Date: Apr 2013
Location: Bangkok, Thailand

Posts: 5
iTrader: (0)

So THAT's where the noise in my car comes from!!!
c-dude is offline   Thailand
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:53 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST