New 2009 2010 BMW Z4 - ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   New 2009 2010 BMW Z4 - ZPOST > BMW Z4 Forum (E89) > 2009-Current Z4 Forum (E89) General Discussion

Post Reply
 
Thread Tools Search this Thread
      11-13-2011, 05:52 PM   #45
ChuckB
Lieutenant
 
ChuckB's Avatar
 
Drives: 2009 BMW Z4
Join Date: Mar 2008
Location: Hockenheim, Germany (APO)

Posts: 446
iTrader: (0)

Garage List
Quote:
Originally Posted by ///MMB View Post
I took a couple of pix, this is the best one I have;

http://i.imgur.com/DnYl7.jpg

If you want to look at your own you can do so with our much work, the cover comes off pretty easy.
I have a European model so my rear fog light works, was trying to verifiy for all who watch this thread if the US models had the Rear Fog light wiring in place:

Purple [Thin Wire]
Black [Thin Wire]
Yellow w/Black Stripe [Thin Wire]
Yellow
Green
Brown w/Black Stripe
Green w/Yellow Stripe, or maybe Yellow w/Green Stripe
__________________
2007 E81 - 120d Limited Sport Ed
2009 E89 - sDrive3.0
ChuckB is offline   United_States
0
Reply With Quote
      11-14-2011, 08:53 PM   #46
syd53
Enlisted Member
 
Drives: 2011 128i coupe
Join Date: Jul 2010
Location: central IL

Posts: 38
iTrader: (1)

Would someone who has had their switch out please check again to see if ours have these 7 wires.
syd53 is offline  
0
Reply With Quote
      11-14-2011, 09:18 PM   #47
///MMB
Member
 
Drives: 2013 911 | 2014 M6 CP
Join Date: Jan 2008
Location: Maryland

Posts: 294
iTrader: (0)

Garage List
2014 BMW M6 cp  [0.00]
2013 VW Beetle  [0.00]
Quote:
Originally Posted by ChuckB View Post
I have a European model so my rear fog light works, was trying to verifiy for all who watch this thread if the US models had the Rear Fog light wiring in place:

Purple [Thin Wire]
Black [Thin Wire]
Yellow w/Black Stripe [Thin Wire]
Yellow
Green
Brown w/Black Stripe
Green w/Yellow Stripe, or maybe Yellow w/Green Stripe
Quote:
Originally Posted by syd53 View Post
Would someone who has had their switch out please check again to see if ours have these 7 wires.
I'll check it tomm
__________________
2014 M6 CP vert | 2013 991 911
///MMB is offline   United_States
0
Reply With Quote
      11-22-2011, 07:55 AM   #48
z4z4z4
Lieutenant
 
z4z4z4's Avatar
 
Drives: 2002 M3, 2011 Z4, & her 740Li
Join Date: Mar 2010
Location: mild mediterranean breezes

Posts: 518
iTrader: (1)

Quote:
Originally Posted by ///MMB View Post
Looks like its possible but parts are missing; the rubber mat that makes the connection on the green board, and to connector between the button and the rubber mat.


This was all that was in there;
Can you make the same custom (missing) pieces as the 08 M3 did in post #20 from Rolf-Dieter's second link above?
http://www.m3post.com/forums/showthread.php?t=531296


"Just did this, took a little extra effort since I have an 08 E92 (no plastic stalk/ lego piece). My method was three fold:

1) Pen cap (acts as a plastic stalk to push the custom flat surface)
2) Pen cap connects to a small cut out credit card square plate (use any old credit card) - cut two squares to fit into the space
3) Sandwich double tape between the two credit card squares, adjust thickness as needed (by adding more double tape. Trail and error until you feel the two rubber buttons are pushed by the switch.'
__________________

BBS-ER-HPF-iJDM-LUX-MachtSchnell-PSS-Remus-Tekarbon
z4z4z4 is offline   United_States
0
Reply With Quote
      11-22-2011, 09:46 AM   #49
///MMB
Member
 
Drives: 2013 911 | 2014 M6 CP
Join Date: Jan 2008
Location: Maryland

Posts: 294
iTrader: (0)

Garage List
2014 BMW M6 cp  [0.00]
2013 VW Beetle  [0.00]
Quote:
Originally Posted by ///MMB View Post
I'll check it tomm

Sorry, I've been kind of lazy about checking, I'm going to wait till the weather around here get better.


Quote:
Originally Posted by z4z4z4 View Post
Can you make the same custom (missing) pieces as the 08 M3 did in post #20 from Rolf-Dieter's second link above?
http://www.m3post.com/forums/showthread.php?t=531296


"Just did this, took a little extra effort since I have an 08 E92 (no plastic stalk/ lego piece). My method was three fold:

1) Pen cap (acts as a plastic stalk to push the custom flat surface)
2) Pen cap connects to a small cut out credit card square plate (use any old credit card) - cut two squares to fit into the space
3) Sandwich double tape between the two credit card squares, adjust thickness as needed (by adding more double tape. Trail and error until you feel the two rubber buttons are pushed by the switch.'
No bc I would still be missing the rubber mat;
__________________
2014 M6 CP vert | 2013 991 911
///MMB is offline   United_States
0
Reply With Quote
      11-22-2011, 10:33 PM   #50
rmorin49
Major
 
rmorin49's Avatar
 
Drives: 11 335d/10 Z4 s30i
Join Date: Nov 2006
Location: Hagerstown, MD

Posts: 1,159
iTrader: (1)

I removed my light switch and the wiring for rear fogs is not installed in the car so even if you install a Euro switch it won't work. Don't know if the bulbs are there.
__________________

Colonel (Retired), US Army/Hagerstown, MD
ED-01-10 2010 Z4s30i AW/Beige/Burl/ 6MT/SP/PP/CWP/NAV/ipod/USB/CA
2011 335d BS/Oyster/PP/CWP/NAV/ipod/USB(Daily Driver) 30+ mpg
1988 635CSi black/tan/5MT/Dinan chip/B&B exhaust/RD sway bars/Bavauto stress bar
rmorin49 is offline   United_States
0
Reply With Quote
      12-19-2011, 01:10 PM   #51
rtzx5
New Member
 
Drives: 2011 Z4 35i
Join Date: Jul 2011
Location: Cambridgeshire, United Kingdom

Posts: 15
iTrader: (0)

There is more to this. I am in Germany right now with a U.S. Spec 2011 Z4 35i. I am trying to get my rear fogs working as I am moving to the UK next month.

Mine has the 6 wires, and I have changed the switch as well as the rear lights (for UK). Of course it is not working. It may be the missing 7th wire but I doubt it, here is why:

The cable assemblies for the US and EU spec cars are the same according to Realoem. The only difference in part numbers is if the car has adaptive headlights.

My wife has a Mini and we are in the same boat with it. Here is a difference though. I have read that the car has to be reprogrammed to recognize the 5AA option. I would bet the Z needs to be programmed as well.

Any thoughts?
rtzx5 is offline  
0
Reply With Quote
      12-19-2011, 02:37 PM   #52
///MMB
Member
 
Drives: 2013 911 | 2014 M6 CP
Join Date: Jan 2008
Location: Maryland

Posts: 294
iTrader: (0)

Garage List
2014 BMW M6 cp  [0.00]
2013 VW Beetle  [0.00]
Quote:
Originally Posted by rtzz4 View Post
There is more to this. I am in Germany right now with a U.S. Spec 2011 Z4 35i. I am trying to get my rear fogs working as I am moving to the UK next month.

Mine has the 6 wires, and I have changed the switch as well as the rear lights (for UK). Of course it is not working. It may be the missing 7th wire but I doubt it, here is why:

The cable assemblies for the US and EU spec cars are the same according to Realoem. The only difference in part numbers is if the car has adaptive headlights.

My wife has a Mini and we are in the same boat with it. Here is a difference though. I have read that the car has to be reprogrammed to recognize the 5AA option. I would bet the Z needs to be programmed as well.

Any thoughts?
It's possible, you either need to buy the OBDII cable from eBay or get some one to do it for you.
__________________
2014 M6 CP vert | 2013 991 911
///MMB is offline   United_States
0
Reply With Quote
      12-19-2011, 02:55 PM   #53
ChuckB
Lieutenant
 
ChuckB's Avatar
 
Drives: 2009 BMW Z4
Join Date: Mar 2008
Location: Hockenheim, Germany (APO)

Posts: 446
iTrader: (0)

Garage List
Quote:
Originally Posted by rtzz4 View Post
There is more to this. I am in Germany right now with a U.S. Spec 2011 Z4 35i. I am trying to get my rear fogs working as I am moving to the UK next month.

Mine has the 6 wires, and I have changed the switch as well as the rear lights (for UK). Of course it is not working. It may be the missing 7th wire but I doubt it, here is why:

The cable assemblies for the US and EU spec cars are the same according to Realoem. The only difference in part numbers is if the car has adaptive headlights.

My wife has a Mini and we are in the same boat with it. Here is a difference though. I have read that the car has to be reprogrammed to recognize the 5AA option. I would bet the Z needs to be programmed as well.

Any thoughts?
I suspect REALOEM must be wrong, I deffinatly have 7 wires. Sent a PM in case we can get together and do a direct compare.
__________________
2007 E81 - 120d Limited Sport Ed
2009 E89 - sDrive3.0
ChuckB is offline   United_States
0
Reply With Quote
      12-19-2011, 03:46 PM   #54
rtzx5
New Member
 
Drives: 2011 Z4 35i
Join Date: Jul 2011
Location: Cambridgeshire, United Kingdom

Posts: 15
iTrader: (0)

@ ChuckB, I will pull mine tomorrow if it is not too cold, you know how it has been here.

The prt number was different for EU cars with S524 I think it was, (which is cornering lights). So if your ride has the adaptive lights, the 7 wire should be there as it is.

Otherwise yeah, they may have it jacked up.
rtzx5 is offline  
0
Reply With Quote
      02-02-2013, 11:16 AM   #55
Rafale
Zed Quatre
 
Rafale's Avatar
 
Drives: '11 Z4 35is & '11 535xi GT
Join Date: Jun 2010
Location: Portland, OR. USA

Posts: 411
iTrader: (1)

Garage List
one year old thread and the winter made me think about this again. My car has the S524A so I am going to attempt the retrofit... Ordering the switch now.
__________________
Rafale is offline   France
0
Reply With Quote
      02-06-2013, 09:32 PM   #56
BMWZ4RIDER
BMWZ4Rider
 
BMWZ4RIDER's Avatar
 
Drives: 2009 BMW Z4 35i
Join Date: Dec 2012
Location: Cape Cod, MA

Posts: 590
iTrader: (0)

I just read this thread. I would be interested in the results for this mod.
__________________
2009 BMW Z4 35i/SMG/DCT/Premium,Cold, Sound PK/Com Acc/Ash/PDC/Wind Deflector/Smoked Reflectors/Red Calipers/Cl Mask/M Series Grill/6000K LED's/De-Badged/M Pedals/CF Mirrors/Stubby/20% Tint/H8 LED's/LCI Side Markers/Super Sprint Spoiler/VMR V710
BMWZ4RIDER is offline   United_States
0
Reply With Quote
      03-08-2013, 06:20 PM   #57
Rafale
Zed Quatre
 
Rafale's Avatar
 
Drives: '11 Z4 35is & '11 535xi GT
Join Date: Jun 2010
Location: Portland, OR. USA

Posts: 411
iTrader: (1)

Garage List
just finally got to look into this. Tried installing the unit in my is and it does not seem to work. My harness only has 6 wires.
I have not yet pulled my 30i. I may take a look at it too.

Will try to see if coding is needed.
__________________

Last edited by Rafale; 03-08-2013 at 06:31 PM.
Rafale is offline   France
0
Reply With Quote
      03-08-2013, 10:12 PM   #58
Rafale
Zed Quatre
 
Rafale's Avatar
 
Drives: '11 Z4 35is & '11 535xi GT
Join Date: Jun 2010
Location: Portland, OR. USA

Posts: 411
iTrader: (1)

Garage List
Quote:
Originally Posted by rtzz4 View Post
@ ChuckB, I will pull mine tomorrow if it is not too cold, you know how it has been here.

The prt number was different for EU cars with S524 I think it was, (which is cornering lights). So if your ride has the adaptive lights, the 7 wire should be there as it is.

Otherwise yeah, they may have it jacked up.
Ok, my 30i also only has 6 wires in the harness... both have option S524A. So much for the theory.
__________________
Rafale is offline   France
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:24 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST