View Single Post
      07-25-2012, 03:54 PM   #115
baldguyj
Private First Class
 
baldguyj's Avatar
 
Drives: 2010 Z4 e89 35i Sdrive
Join Date: Dec 2011
Location: Florida

Posts: 105
iTrader: (0)

Let us know how it goes, I'm almost to the end warranty so might make purchase soon as well!
Quote:
Originally Posted by Seechun View Post
Just installed ESS tonight and the results are sweet!

Review of the process:

- Received the ESS kit within a week after ordering (AUS)
- Installed software but did not recognise the USB connector cable, tried several computers with no success (FYI windows only, I used VMware to install the software)
- Sent email to ESS and received an updated software version (I suggest you guys include this in the USB instead of the older version)
- Took just over 1 hour to download the stock ECU (much longer than expected so if you are planning to do it make sure you allow enough time...as you can't stop once you start it
- Emailed stock flash and received back next day
- Uploaded new ECU and only took 15 mins total, a few warning messages came up on the LCD such as transmission error, etc but when the tune was finished just pressed OK and they all dissappeared
- Short test drive and back to check error codes
- No errors so all went well!

Initial results, the car definitely takes off faster and you can feel the power coming more immediately than before. In sports+ mode this makes the most difference and the gear changes sound a lot clearer now, kind of gives out a short blurp sound every gear change now

No significant sound changes for idling and minor acceleration sound improvement

Overall an awesome investment, easy to use (plug and play), and looking forward to trying out the car at the track this weekend!
baldguyj is offline   United_States
0
Reply With Quote